SmartThings Community

VLC Thing. A Poor Man's Sonos. Version 2.0 Released 12/22/2016

dth_voice
tts
dth_av
communitydevices
dth_alerts
(Cesar Galván) #81

Hello, I’m having the exact same problem still with the Yellow Connect Tile, but controlling everything ok, any help how can I solve this?

0 Likes

(Geko) #82

You need to set deviceNetworkId manually in the IDE.

0 Likes

(Cesar Galván) #83

Fully Working now! Thank you

0 Likes

(Josh) #84

For some of the Sonos apps, you can choose a song to play…but there are none listed in my ST app. How can I choose a song to play?

0 Likes

(Josh) #85

How can I populate this with songs from the VLC player, or with MP3s to send to the VLC Thing?

0 Likes

(Geko) #86

VLC Things tries to emulate Sonos as much as possible within the constraints of the available remote control API, but it’s not Sonos. If you need full Sonos functionality, you should get the real thing.

0 Likes

(Josh) #87

Roger that. Thanks for the reply.

0 Likes

(Vagelis F ) #88

When I choose custom message I hear half the audio.Audio clipping as
@mattjfrank said above.

I am using a chinese tablet (Teclast X98 Air 3G) with Windows 8.1 Pro and VLC installed.
I am also trying to enable speech synthesis with Smart Alarm app but nothing comes out of the speakers.

Thw Win 8.1 tablet is connected with my Samsung HT 5500W via Bluetooth so Sound is heard…saves me buying a battery-powered Alarm…for the time being.

What I want is to have a simple phrase such as “Office motion detected” but unfortunately I hear half of it as I say.
Moreover with Smart Alarm am trying to implement the text to speech to both VLC Controller and Ubi app.

Any ideas about the sound clipping ?

0 Likes

(Yann Oehl) #89

Unable to trigger sound events…
I’d been running VLC Thing 1.1.0 without fail a few weeks back. However, about a week ago or so it just stopped. I’m able to access VLC Remote via local host on both my desktop and iPhone… And I can see an http post being made when I set a virtual device in the debug console. However, the actual “device” seems totally dead. No test text is synthesized, and the activity log only shows volume changes… No other smart app appears to be able to trigger an event.
I’ve tried reinstalling the device type and device. Still no joy.
Any troubleshooting tips appreciated

0 Likes

(Amauri Viguera) #90

Did you check that the network ID is set in the IDE?

My VLC Thing was working for the longest time, and all of the sudden it stopped working with that change they made in the backend recently. I poked at it for a while, even accessing the URL directly and verifying everything was good, then decided to edit the device and manually add the Device Network ID and save it, then things started working again.

0 Likes

(Yann Oehl) #91

Thanks for the suggestion Amauri.
I looked and it seems valid looking (C0A8010E:1F90) although I’m not certain. How would I double-check the device id? Or do you mean replacing the line “device.deviceNetworkId = “${hexIp}:${hexPort}”” in the device code with device.deviceNetworkId = “C0A8010E:1F90”?
Ill try that…

0 Likes

(Amauri Viguera) #92

That translates to 192.168.1.14 on port 8080, so if that seems right then that’s no tthe issue.

0 Likes

(Yann Oehl) #93

Yeah… thats the right ip address… I’ll try reinstalling everything from scratch and see if that jiggles the handle.

0 Likes

(Yann Oehl) #94

Problem fixed. My bad. Had a crazy firewall rule that prevented communication to my hub. Works a treat now.

1 Like

(Amauri Viguera) #95

I once had an issue where something else was running on the same port, so you’d be surprised how easy things are to overlook :smile:

Glad you got it fixed though.

0 Likes

#96

Does anybody else get double the volume in vlc relative to the settings for vlcthing?

This was causing bad distortion when playing through airfoil if the vlc volume went above about 95%.

0 Likes

#97

Hey @geko - this thing kicks all sorts of ass! I have Sonos all over the place but I just can’t seem to get ST to reliably deal with it. As it turned out, I had a system already connected into a full-time audio setup and as a result it took me maybe 15 minutes start to finish to have it up and broadcasting alerts. This thing is easy and awesome and thanks for sharing it with us!

1 Like

#98

Anyone find a solution to the https problems for VLC under Windows. Any url with https fails. For instance the “test button” under the “VLC Thing” calls https://s3.amazonaws.com/smartapp-media/tts/68259880f3736fdd64c9bdc16bce665c3c3acfc3.mp3 This url will work fine within my browser but fails in VLC.

0 Likes

(Ule) #99

Hi , like in my previous post replace the “https:” from the url to “http:” in all uri comands, uri -> uri.replace(‘https:’, ‘http:’) and now VLC works fine.

If you have a media network speaker or a Smart TV you can try the DLNA media renderer device

2 Likes

#100

How can I replace the https??? The URL is generated by the app. For instance, pressing the “test” button on the VLC Thing app calls “https://…” I cant see where/how I can change that??

0 Likes