VLC Thing. A Poor Man's Sonos. Version 2.0 Released 12/22/2016

Thanks Geko works great now. My plan is to connect them to the lighfreqs I ordered through kickstarter when ever they come in. Even if they don’t directly connect to ST, I should be able set them up as speakers through VLC and use VLC Thing as my voice for ST.

1 Like

foobar2000 (just for windows) have a component to send output to a upnp media render, can be controlled by html, and allow multiple instances, this player can replace vlc to send music and alerts directly to any dlna or upnp media render, currently works with “Samsung TV, WDTV [limited success, WDTV firmware is extremely buggy], BubbleUPnP, foo_upnp, dBpowramp uPlayer”, this is not a push dlna , its a streaming , no all mediarenders works , but maybe can works for you.

Hey

Great App! Is it possible to have a song played when a door is opened? I went through the Sonos Mood Music App but got I stuck where it wanted to add a song as there was no where no way to choose a song. I am sure I am missing something.

thanks

Ron

I got this working like a champ on my Windows based desktop. I am trying to get this to work on my Raspberry Pi (model B+) so I can hook them to speakers and have a streaming capable speaker in all the rooms.

here is my main issue that I cant seem to get around no matter how much google-fu i apply.

I am using the base install of raspbian wheezy. I install vlc. now, when I manually run the command from the command line to start the command line version of vlc it works fine.

something like this: cvlc --http-host=192.168.2.20 --http-port=8150 /etc/vlc/streaming.m3u
I add that same thing to a startup script, and it doesnt load properly.

has anyone worked with raspbian and vlc enough to be able to start VLC on boot via the command line, and have it load properly?

it doesnt help I am a linux noob lol.

Hello, I’m having the exact same problem still with the Yellow Connect Tile, but controlling everything ok, any help how can I solve this?

You need to set deviceNetworkId manually in the IDE.

Fully Working now! Thank you

For some of the Sonos apps, you can choose a song to play…but there are none listed in my ST app. How can I choose a song to play?

How can I populate this with songs from the VLC player, or with MP3s to send to the VLC Thing?

VLC Things tries to emulate Sonos as much as possible within the constraints of the available remote control API, but it’s not Sonos. If you need full Sonos functionality, you should get the real thing.

Roger that. Thanks for the reply.

When I choose custom message I hear half the audio.Audio clipping as
@mattjfrank said above.

I am using a chinese tablet (Teclast X98 Air 3G) with Windows 8.1 Pro and VLC installed.
I am also trying to enable speech synthesis with Smart Alarm app but nothing comes out of the speakers.

Thw Win 8.1 tablet is connected with my Samsung HT 5500W via Bluetooth so Sound is heard…saves me buying a battery-powered Alarm…for the time being.

What I want is to have a simple phrase such as “Office motion detected” but unfortunately I hear half of it as I say.
Moreover with Smart Alarm am trying to implement the text to speech to both VLC Controller and Ubi app.

Any ideas about the sound clipping ?

Unable to trigger sound events…
I’d been running VLC Thing 1.1.0 without fail a few weeks back. However, about a week ago or so it just stopped. I’m able to access VLC Remote via local host on both my desktop and iPhone… And I can see an http post being made when I set a virtual device in the debug console. However, the actual “device” seems totally dead. No test text is synthesized, and the activity log only shows volume changes… No other smart app appears to be able to trigger an event.
I’ve tried reinstalling the device type and device. Still no joy.
Any troubleshooting tips appreciated

Did you check that the network ID is set in the IDE?

My VLC Thing was working for the longest time, and all of the sudden it stopped working with that change they made in the backend recently. I poked at it for a while, even accessing the URL directly and verifying everything was good, then decided to edit the device and manually add the Device Network ID and save it, then things started working again.

Thanks for the suggestion Amauri.
I looked and it seems valid looking (C0A8010E:1F90) although I’m not certain. How would I double-check the device id? Or do you mean replacing the line “device.deviceNetworkId = “${hexIp}:${hexPort}”” in the device code with device.deviceNetworkId = “C0A8010E:1F90”?
Ill try that…

That translates to 192.168.1.14 on port 8080, so if that seems right then that’s no tthe issue.

Yeah… thats the right ip address… I’ll try reinstalling everything from scratch and see if that jiggles the handle.

Problem fixed. My bad. Had a crazy firewall rule that prevented communication to my hub. Works a treat now.

1 Like

I once had an issue where something else was running on the same port, so you’d be surprised how easy things are to overlook :smile:

Glad you got it fixed though.

Does anybody else get double the volume in vlc relative to the settings for vlcthing?

This was causing bad distortion when playing through airfoil if the vlc volume went above about 95%.