Vivint & Smart Things

I am in the same boat. Basically my attempts at using ST with Vivint has been a fail.

My contract with Vivint ends this month. After numerous attempts and multiple partial successes, the Vivint panel became completely bogged down and barely functioning. I finally did a factory restore and had to call Vivint and get them to add my panel back into their system. I then added all of the 345mhz security devices back into the Vivint controller. Vivint has since upgraded my panel to 3.10.xxx and now I also have to call them to unlock the panel that I technically own.

My experience has been that Smartthings will recognize the locks and thermostats but as Isckk5 mentioned above, they will become unresponsive. When they do I have been able to “wake them up” by going into the settings for the device in ST (clicking on the gear in the top right) and then clicking done. Which seems to save the device and re-establish communications. This is quite frustrating and I am now ready to walk away from the Vivint control panel.

I am now considering the ADT rebranded 2Gig panel or to either the 2Gig GC2 or GC3 panel. I would prefer to self monitor or pay no more than 20/mo for monitoring.

Any help or suggestions are comments from personal experience with this combination would be appreciated.

Could you please provide some exact instructions on how you pulled this off?

Looks like Vivint has caught on and disabled the Toolbox access. I’m on software version A.01 3.9.0.22862

LEARN CONTROLLER is no longer an option. The capabilities I have found under the Z Wave tree is to initiate a generic device detection script. I plan to chat with support to see if they can trigger detection mode of their panel from the server side.

As Danny mentioned, you can call Vivint and tell them to unlock the installer access, but it will default back to locked after a period of time.

Once I’ve added the Vivint Panel as a secondary controller in ST, Should it have any functions in the ST app? It shows up but it doesn’t do anything. Also, the door contact sensors are showing up in the Vivint Panel but not in ST. Any ideas on what I can do? Should I just erase all the devices again and start over? (that would be a pain, as i have to take down the garage door opener and bring it in the house so it is close enough to pair with the vivint panel.)

@Josh11 the Vivint sensors are not Z-Wave. They will not show up in Smartthings.

…I can’t find the best place to post this but I think this might be it…

QUESTION: I’m having a hard time finding zwave sensors that are guaranteed to work with my vivint Skypanel, and obviously the Vivint chat people just tell me nothing is “guaranteed” to work but their stuff…but I don’t want to pay $70 for one of the Vivint water sensors when i can get one smartthings water sensor for $20…?

I need water sensors that work with my vivint panel…?

Thanks.

When you say water sensor are you talking about a flood sensor? If so giving does not have vivint branded flood sensors.

Sorry for bringing up an old thread… so I attempted to follow these directions and I’m not getting any where. I attempted to add the panel and get what’s included with the picture next to the ST hub. I then installed my garage door opener, it only shows up on my vivint panel. Installed the front door lock, it only shows up on the vivint panel (it won’t lock or unlock from the panel or the app). Neither of them showed up in the ST app. Dear Lawd, what have I messed up now?

Any ideas on Steven’s question? I have the same issue. Vivint is associated but no functionality. Thanks.

Likely you should use the classic app. Your picture is the new.

I am having the same issue.
I tried with the classic app and the new app.
I tried adding the vivint panel as a secondary controller to ST hub and also the ST hub as a secondary controller to the vivint panel.
Everytime the vivint panel does appear in ST app (classic and new) and the ST hub is listed in the nodes of the vivint panel.
When i add a zwave device (like a lock) via the ST hub it is listed and working (in both classic and new ST app), however the lock does not appear in the vivint panel.
i was hoping it would be listed and operational from the vivint panel as well.
May be my expectation were too high.

Found this thread and now trying to integrate my 3 day old vivint panel to my Smarthing Hub
Vivint A.01 3.19.2.28098
STH-ETH-200.(V2.2015)

No luck yet. Can anyone confirm that the STH-ETH-200 V2 can integrate with the new Vivint Panels or do I need the V3 ST hub?

I have been using the steps mentioned by @redfire1539 by removing all associated devices. It gets annoying having to call Vivint to unlock the installer toolbox though.

I did try connecting the ST hub as a node to the Vivint Panel and it worked, but there were issues with some Zwave switches misbehaving. So, I am looking to get the Vivint Panel added as a secondary controller to the V2 hub.

@tenor0 that’s interesting… My old firmware had no problems adding SmartThings (3.12.x I forget exact version but pre 3.19) hub, but now when I go to Z-Wave learn controller - the Vivint panel gets stuck at “initializing learn mode”. Is that what’s happening to you too? Seems like a Vivint panel issue because when my panel wasn’t getting stuck at that - it was working just fine. My fw is 3.19.2.28437.

@gr33k Yes. It is stuck at “initializing learn mode” on the panel. Tried it many times, with NO devices attached to either, but it just does not work even after waiting for over an hour. Guess Vivint blocked this from happening in their new 3.19 FW. Thats a shame ;-(

I hope it’s just a bug - I emailed their beta team and haven’t heard back. I’m told the firmware I was on is currently the latest and a newer version is due out in Sept (perhaps the 3.20.x). I really hope it’s just a bug because right now it’s not possible to pair SmartThings anymore with Vivint because of this. Fortunately - most customers will NOT be on this beta firmware - and previously pair devices should continue to work I believe. Just keep in mind and avoid updating :wink:

Yes the panel gets stuck, but it show up in smart things as a controller with no functions. All my switches from Smartthings show up in Vivint as multilevel z-wave device (all GE dimmers), the names do not copy, motion sensors dont appear to show up in Vivint though. The vivint thermostats/ kwickset doorlocks from Vivint show up in smartthings. Also all these devices duplicate themselves on Alexa. The Smartthingsbhub does not show up in the Vivint panel.

Thermostats stop responding through vivint and door lock is also intermittent (or very slow to update)

I find that if I remove things like z-wave plugs and move them to other locations in the house, I start getting unavailable switches/motionsensors in smartthings after power outages.

I finally gave up and separated the two.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.