View temp not motion

@Paulo, rest assured it does still work and it allows changing. I’ve personally done that on dozens of devices I have.

What kind of sensor is that?

Try clearing out cache, all data, and force stopping the app, as well as logging out.

The best way to do what you want right now as V2 app does not support tile changes is to create virtual temperature tiles and then use a smartapp to mirror the real temperature device.

@johnconstantelo, just tried it again. Force stopped app > cleared cache > cleared data > uninstalled app. Installed old app from a backup APK. Still no luck. Half the icons are blank and when I click on the setting area in the upper right corner the app eventually crashes. It is a PEQ Motion sensor. I have a few of these installed and only the one that was installed after the update defaulted to motion. I hope that this will eventually get addressed by the developers as it is a bit of a pain.

Sorry to hear about that @Paulo. I have about 10 of the PEQ’s myself, and I can still change things in the old app.

What version of the old app are you running? I’m at 1.7.6 on my tablet.

Not sure if anyone is still looking to change the default display on the mobile app, but I was able to by using the simulator in the IDE. I have three temp/humidity sensors that showed the temp by default. I chose a code template that required a humidity sensor, picked the sensor I wanted to change, then clicked on the config gear in the top right. I could then change which data tile to display, which also changed the default display in the mobile app.

Hope that helps!


I’m not sure if you’re still looking for a solution, but if you want an easy way to view all of your temperature sensors on one screen you should try this app:


I currently use a SmartTiles dashboard with just my sensors but this looks great. Thanks.

I just noticed one of my PEQ motion sensor defaults to Motion also, I changed the device type to motion/temp like the others but it still reports motion by default. Any way to change this from within the app or ide? There is no option in my ST app.

Not with v2.x.x of the app, but you have a few options:

  • If you have an Android device, you can go back to version 1.7.6. That version let’s you change what is default. Once done, go back to version 2.1.3.
  • Use the IDE. Look up at post #22
  • You could make your own copy of the device handler and change what the default is. I don’t recommend this.
1 Like

I finally got around to doing this tonight and your suggestion on getting the 1.7.6 app worked perfectly.

1 Like

Has anyone been able to follow this procedure? I don’t understand how to use the simulator to get to “the config gear in the top right” - is this in the browser?

I can change the device-handler ordering of main capabilities and get the result I want (temperature of SS Multisensor) - I’d rather not change the device-handler.

Also where can I get a copy of the 1.7.6 .APK? I find some repositories but how do you prevent a trojan?

Thought we’d be able change defaults natively by now.

I was using the browser simulator for custom SmartApps at:

The gear shows up after you select a sensor. However, I just tried the simulator a few minutes ago and I can’t even get it to set the location. Not sure if it’s just a temporary bug or if it’s because of a recent firmware upgrade. Either way the simulator doesn’t work for me now.

I really wish they would just let us pick the default display through the mobile app.

1 Like

OK!!! got it - it worked just now - first time using the simulator. I haven’t seen a tile gear for MANY months - thanks!

Nice! I still can’t get the simulator to work with my hub. Which browser were you using?

Chrome, whatever is current yesterday. Hub is v1.

Does this trick still work? I have a V1 ST multi that is defaulting to Temp. I’m using it as a door contact but I do not have the option of selecting that even in the simulator :frowning:

Yes, it should. I did that to a couple of my V1 ST muli sensors a couple of months back.

Does yours use SmartSense Multi device type?

Yes I do, I made the modification and renamed it SmartSense Multi Movement because I wanted to track acceleration.

Thanks. Strange deal, I should probably just mount one of the dang monoprice sensors and save me the grief of figuring it out. :slight_smile: