Very Weird - strange Tilt Sensor Behavior


(Monte Montemayor) #1

I have the MyQ + Chamberlain ST app installed using a EcoLink Tilt sensor and due to various network upgrades around my home, I ended up breaking the tilt sensor connection to ST. I had to use the Z-Wave General Device Exclusion process to remove and then use ST to re-pair my EconLink Tilt Sensor to ST. Doing this in my living room, everything works great. But… when I take it to my garage, it doesn’t work anymore.

In other words, holding it my hand in my living room, when I physically tilt the sensor, ST registers is as Open/Close. In the garage, it doesn’t work. Taking back into the house and re-trying it, it works perfect. The strange thing is that this same sensor on the same garage in the same house has worked perfectly for months. I’m stumped. Any ideas? I suspect something weird is going on with the Z-Wave network but I have no idea what.


(Eric) #2

try Zwave Repair = phoneapp/ MyHome/ menu/ gear-icon/ HubIsOnline/ Zwave Utilities/ Repair .

Things change all the time.


(Monte Montemayor) #3

Thank you E - I’ll give that a try.


(Monte Montemayor) #4

Hi everyone - i am really perplexed by this issue. I have tried unpairing/deleting the tile sensor. Using the Utilities to delete the Thing. Then per ero4444, i tried Repairing the Zwave then re-adding the Tilt Sensor. Here’s what’s happening: Inside of my home, when I physically move the sensor straight up or sideways I can see the correct reading inside of the ST app. But as soon as I go into my garage, it no longer works. Standing inside the door to the garage it works but when i take a few steps into the garage, it no longer works.

This used to work just fine. I dont know much about zwave but I do know that wifi is strong in the garage. I have the google mesh network in my home and I have a node right on the other side of the wall from the tile sensor which is where the node is.

Any ideas out there?


#5

When you ran The zwave repair, did you have the sensor in its desired position in the garage? Or did you have the sensor in the house?

If you ran Z wave repair before you added the tilt sensor, that won’t help at all. The idea of the Z wave repair in this particular situation is so that the tilt sensor will find its most helpful neighbor in getting messages to and from the hub.

Z wave repair can only work if all the devices are in their operating positions. Otherwise they will select the wrong neighbors.

So add the tilt sensor, then put it where you want it to be in the garage even if you just tape it in place temporarily, and then run a zwave repair. It can take a while for all the individual address tables to get updated, so you may not see improvement until the next day. Leave the sensor in place until then.


(Monte Montemayor) #6

“When you ran The zwave repair, did you have the sensor in its desired position in the garage? Or did you have the sensor in the house?” I had it in my hand in the living room. Thanks for more insight on how that works. I’ll give that a try. Thanks JDR.


(Monte Montemayor) #7

Well dang, that didn’t work. I deleted the Tilt Sensor, used the Z-Wave Utility to Exclude, re-added the sensor, then did a Z-Wave Repair. No Joy. I am wondering if I should just delete my MyQ Smart App, delete my Ecolink Tilt Sensor and then start from scratch.! I don’t exactly know how to remove the code from the IDE and really start from scratch. {sigh}

13|243x500