V2 Smarthings Hub - Upgraded software - Can't see my Kwikset locks any longer

What I put in the heading says it all.

I got an e-mail from Smarthings that as of Sept, lots of stuff is going away as they are “upgrading”.

So, on my phone I downloaded the latest app, and connected everything with new locations, etc, but when I tried to add my Kwikset locks (910), which were working with the “classic” app, this new app won’t see them.

First of all, it won’t discover them. Then if I try to add them, there is a list for Kwikset 910, but when it trys to add them, it says this very odd instruction about “pressing the A button on the interior of the lock”. Well, there’s no A button on the front of the lock and there’s nothing on the back so I removed the cover and there’s no A button. Then I searched the Internet and Kwikset’s web site, and that turned up nothing on a A button.

I’m thinking this smarthings hub needs to be sold on ebay.

But before I do that, I thought I’d ask for help. Any ideas out there?
I reset the locks by removing the battery, did a Z wave repair, etc.

Link to manual: (shows where button A is)
https://www.manualslib.com/manual/1345309/Kwikset-Smartcode-910.html?page=3#manual

Thank you for the link.

However, pressing A button or not, the new app will not connect the locks to the hub. What was working this morning is no longer working. I also got a long ethernet cable put the hub with 1 foot of the lock. Zippo. I’ve pressed it numerous times and it won’t connect.

I talked with Smarthings support and worked with a tier one tech who also had no idea what the A button was and kept asking me to use the Program button. She had no clue what it was either.

Once I got your link I thought that might be the fix, but its still a no go. It’s a pretty simple procedure - press the A button, it goes red, and then in the app try to connect. But I’ve done it numerous times and nothing. I even scanned to exclude it (just in case) and it didn’t find anything. I also tried a zwave repair and nope, won’t connect.

So now I’m screwed. Fours in, and nothing. I did escalate, but I don’t think Smarthings has anything for me…

Four hours ago, my locks (I have two Kwikset 910 locks, both zwave), my locks worked with Alexa, and now I’ve got nothing.

Exclude the lock first.

In the new app, go to the menu (3 bars in the upper left of the screen)
Choose Devices
Find your hub and select it
In the upper right, click on More Options (3 dots)
Select z-wave utilities

1 Like

I got a hold of a great Kwikset tech who helped me fix the problem, adding both locks.

So, this is how it works:

  1. Go to hamburger menu and find the exclude menu.
  2. Press the A button (this is the key, if the A button is not pressed, it won’t successfully exclude), and on my Kwikset locks, the A button is not labelled. The A button is a white button on the left at the top of lock, in the back side of the lock. You have to take the battery cover off, but don’t remove the battery, just remove the cover to expose the buttons and programming console on the rear of the lock.
  3. Make sure the hub is within 12 inches of the lock (this is also important for a Zwave Kwikset lock)
  4. Hopefully it finds a device to exclude - once it does, continue, if not, rinse and repeat
  5. Go back to add device (I did my add this way -> Click the plus sign, Device, Add by Brand, Kwikset, Lock, Zwave 910)
  6. Make sure the hub is within 12 inches of the lock
  7. Press start on the app
  8. Quickly press the A button (these two should be executed very close together)

The app will provide a notification if successful.

2 Likes