SmartThings Community

V2 Hub possibly bricked from ST firmware update

Hi SawKyrom

I’ve just gone back through the main topic to do with the firmware upgrade issues. I think there are around a dozen or so who report that their hubs were bricked, either resulting in solid red lights or solid blue or flashing blue.

It seems to me that our issue has been swamped by a larger number with general hub and z-wave device stability issues.

I am having trouble getting further responses from U.K. support. The first line support person said they would have to enlist support from other more knowledgeable people but then nothing…

So, our systems were working normally, the firmware release happened on 27th March and it killed the hubs stone dead, apparently irretrievably with their comms capability crippled.

Maybe the z-wave stability issues hit more people, or a hub going repeatedly offline is more tangible but having the hub totally killed should be getting more attention, surely?

Does anyone have any ideas on how we can collectively assemble the information on dead hubs and negotiate a compensation?

If a hub is bricked, they’ll replace it. Regarding compensation, read the TOS - you’re not entitled to any. As for the replacement hub, you will have to rebuild. I have 285 devices, it’s not an enjoyable experience. Good luck.

2 Likes

Thanks, John. It seems where I need luck is in getting some kind of coherent response from support. It’s been 10 days now and all I’ve had is a statement that my hub shows the previous firmware version on the ST servers database.

I hope your first sentence about getting the hub replaced proves to be true. That’s the compensation I’m talking about, not the consequential loss. At least a rebuild would give a good chance to clean up my naming standards and legacy, dead devices.

This event has given me a good opportunity to research the current alternatives and relative strengths and weaknesses of different approaches. The various posts of @JDRoberts have been invaluable for this.

ST issues of stability, config backup and migration and cloud processing would be solved, for me, by going to Indigo Domotics. A replacement ST hub would just be a standby for any devices I can’t get into Indigo. Maybe I will struggle with my Samsung webcams and speakers but then again their integration with ST was never that good.

I’m reminded of the old Total Quality Management message: it’s when things go wrong that a supplier can really win customer loyalty by showing their interest in making amends. Or, conversely, losing their customers when they appear to be in denial or disinterested.

1 Like

Mine has been replaced twice.

1 Like

How long have you had your hub? If more than a year, then you might be out of luck. Obviously, they had to cut a lot of things to be able to offer the hub for 60 bucks (support seems to have been hit the hardest).When Wink bricked my hub, I was faced with the same dilemma, do I buy another Wink hub or move to something new. I found SmartThings and I thought it offered a lot more features than Wink. So I went with them, but the Great Winkening thought me a valuable lesson, I cannot be without my home automation for more than 24 hours, let alone for 10 days. Go get yourself a new hub, the longer you wait the worse you will feel. If a switch would have died on you, would you wait for the manufacturer to compensate you, or would you replace it right away?

Add one more solid/blinking blue to the list.
Tried a reset after getting tired of waiting for support. I see that it sends dhcp-request messages, but does not respond to them. After a while it starts sending out some arp-requests with a self-assigned 169.x.x.x address. Trying to ping that address (from a network interface on its self-invented subnet) does not result in a reply.
Seems like something is broken in the tcp/up-stack/firmware preventing it from receiving packets.

The developer web site tells me it got the last ping from hub at 2019-03-27T18:54:08.823Z.

Hi Bob

I got it in 2015 for about £100 in the U.K. It’s not the cost that stops me doing as you suggest. I tend to think the way you suggest and haven’t bothered chasing up suppliers of stuff that breaks. And I agree that ST is cheap for a hub that offers so much.
But I’d rather spend £200 on an Indigo licence. I’ve put quite a lot of effort, time and money into HA and I’ve come to realise that, for me, reliability and backup contingency are worth a bit more than the apparent flexibility of including almost anything.
I know Indigo might be discontinued at some time and I also know that Mac OS upgrades have been known to brick Macs. But at least Apple offer effective support when things go wrong. Indigo seem to have a good reputation too. I’m off.

1 Like

Indigo Domotics is a good choice for many people who only have Z wave and Insteon devices. It is solid and reliable and you control updates since it runs on a laptop.

However, unless things have changed, the last time I looked at it it did not support secure devices like smart locks and keypads. So it will work for some households but not others. Every system has pluses and minuses, the key is to find the one that best matches your own needs and preferences. :sunglasses:

1 Like

Hi JD.

I have Zigbee bulbs too but they are Hue and Lightify which both seem to have plugins for Indigo.
Remote access is also important for me and was a weakness with Indigo according to the stuff I’ve read but that’s been fixed now.
Above all, I don’t want unrequested firmware upgrades taking my system down for extended periods! Nor struggling with a support organisation which seems stretched beyond breaking point.

2 Likes

I too have had my V2 completely bricked by this forced 3/27 firmware update. A few days ago, I got a call from tech support while at work that the issue had been resolved. It hasn’t. Tomorrow I will have gone for two weeks without a resolution. I’ve tried all three versions of resetting it as described by tech support in a thirty minute phone call that had me sit on the phone in quiet with the rep for twenty minutes instead of just calling me back.

Someone suggested that you just run out and buy a new hub. Some of us don’t have that option right now in our budget. Also, any chance you work for Samsung sales? Their V3 is out, and it seems to be working fine. Don’t you want a new hub that in two years time will be bricked by a faulty firmware update?

Someone also mentioned issues with Wink. I too found the Wink to be buggy, which is when I purchased the SmartThings in 2016. It’s functionality has been shakey at best.

The only hub/light solution I’ve had with any reliability or success is Phillips Hue. It runs 1/4 my house, and although it doesn’t seem like it will be able to control the non-phillips light bulbs I have, it is older than the V2 I own and it is still running, flawlessly, with no forced bricking firmware updates. Don’t get me wrong, it just updated a light bulb last week. It’s just that Phillips apparently values its customers enough to test an update before shipping it to customers.

Thank you, Samsung, for making me a loyal Phillips Hue customer, despite the slight uptick in price. I’d rather send my money to the European Union anyways. Anyone need some Sengled zigbee bulbs?

I’m experiencing the same issue. V2 hub alternating between a solid blue and blinking blue light after the most recent firmware update. I have a ticket in with support and have attempted a reset with no resolution. Will continue to check for status updates here and post if I hear anything.

I’ve reached out to support again. They are going to send a replacement hub to correct the issue.

I woke up to the blue blinking light one day. After years of tweaking we finally got everything automated and rarely touched the app. Didn’t even want to think about moving to the new App.

Stopped working completely. Tried to restart it, nothing. I couldnt even see the hub in the app. Reluctantly did the factor restart. Still no hub found.

Submitted a help ticket… waiting over a month for response. Called support, he said sorry you need to buy a new hub. Needless to say I was pissed.
Didn’t have the extra time in my life to research new zwave hubs so we broke down and bought a V3. It’s working but needless to say I will jump ship once a decent alternative comes about.

That’s good to hear. I’ve been dealing with support for almost a month now. Still no resolution. They keep saying they fixed it from their end but I don’t see how that is possible when the hub doesn’t boot.

I have been seeding emails to ST tech support daily for the past 4 days and still no response. The last correspondence from them was 3/29/19…
Anyone else still being ignored?

Best method for reaching ST support is by phone and speaking to a rep. That is, if you are in a region where phone support is available.

Yes I was being ignored via email after a couple conversations. I had to phone in for help.

welp my original hub was returned but without a power supply. I’m back to a week of radio silence trying to get support to respond.

UPDATE:
It’s been awhile so here is a summary of what has happened.

SmartThings v2 hub log summary:

  1. Worked until Wednesday March 27th 2019 @ 3:16pm then offline (solid red LED’s)
    IDE shows version 000.024.0020
    Per ST tech support, tried cycling power, factory reset etc…. Still solid Red LED’s.

  2. Started working again Tuesday April 30th 2019 @ 12:19pm. Worked approximately 21 days.
    IDE shows version 000.025.0026
    Notified ST tech support that the v2 Hub was back online with 100% functionality restored & (as I suspected) it apparently locked up during the “re-boot” of their forced firmware update.

  3. Offline on Tuesday May 21st 2019 sometime after 6:34am. Solid Red LED’s again
    Called ST tech support again. The tech happened to mention that they had another firmware update rollout. Per ST tech support, tried cycling power, factory reset etc…. Still solid Red LED’s.

  4. Started working again Wednesday June 5th 2019 @ 8:33am.
    IDE shows version 000.025.0032
    100% functionality restored once again……. The pattern I see is with the ST firmware updates, during the v2 Hub reboot, it locks up for 21-34 days.

Has anyone else experienced this?

Revised,
Just confirmed that all of the ST multi sensors are NOT working 100%. Acceleration & temp is working but the contacts are not.