V2 Hub Firmware Update

How do I update the firmware on my v2 hub? It’s currently running 000.048.00005.

000.048.00005 is the current production version. Hubs update automatically on a rolling schedule as defined by ST.

You can join the beta firmware group if you want to try the latest beta (which is 000.049.00007). Theres information of how to join on the forums. Unless you’re developing drivers and want to test the latest, or you have multiple hubs to be able to compare beta vs production, I would just stay on the production release cycle.

Thank You! I’m dealing with an issue and there was concern that I had old firmware. Thank you for confirming that I’m current.

what is the issue? :slight_smile:

A few days ago, a couple of switches (1 Inovelli and 1 Leviton) disappeared from the app. I may have accidentally removed them by leaning a box against them – I’m not sure.

When I try to add either of them by going the brand/type route, I get a message that reads “Couldn’t add device. You first need to get access from the owner of the location before you can add this device to your locations.” It’s my house, my hub, my phone, my app. I installed them 3+ years ago.

I went into the location (hub) and looked to see who the members are, which is me (only me). For fun, I tried to invite a member, and it said I couldn’t invite myself.

I tried scanning the QR code, and just got the above message.

This morning, I updated the app, Reset the switches, but scanning for devices didn’t find them. Like many other manufacturers, when I tap Inovelli, nothing happens. It lightly changes appearance (like tapping any icon on a smartphone does) but it doesn’t open another page or function. Leviton advances to the “Scan QR Code” page. As I don’t have a QR code for this switch, I tap “Add without QR code.” Nothing at all happens. It’s as if I didn’t even tap it (other than hearing a click). I’ve tried restarting my phone, but no change in that.

Rebooting the hub made no difference.

have you run z-wave exclusion on them?

No. Since they don’t appear, I didn’t think there was anything to exclude.

try excluding them one at a time… then you should be able to pair them again.

strange how they disappeared.

Tried excluding the Inovelli and got a red light, which means unsuccessful. I’m doing a Z-Wave network repair right now.

no, you want to do the z-wave exclusion. put the hub into exclusion mode and perform the steps required on your two devices. generally pressing the switches until you get the successful exclsion

Yes, I did the exclusion on the Inovelli and got a red light, which means that the exclusion was unsuccessful. I’m doing a repair to see if there’s anything amiss with the network.

I had a problem excluding some switches in the past, and if I remember correctly the switch routed through another ZWave switch. I resolved it by putting the hub on a long ethernet cable and placing it within 10’ or so of the switch. The exclude worked correctly, I put the hub back in its normal place, and I was able to add the switch normally.

your best friend to exclude is a minimote. they arent made anymore, but can be found every once in a while on ebay for around $29-30. they still would as a remote too.