Using Google Home to control my Fibaro Switch Double doesn't work with "Turn on all the lights"

Hi everyone! I have a Fibaro Switch Double I use to control my Kitchen Ceiling Lights. In the same kitchen but on a different wall switch I also have some Phillips Hue lamps. All were added to Smartthings but when I say “Hey Google, turn on the Kitchen lights” only the Phillips hue light up. After some digging I figured that is because it doesn’t recognize the switch as “lights” and, as such it doesn’t respond to any commands that include lights, like “Shut down the Kitchen lights”.

Someone having the same issue that found a workaround?

Thank you

Does Google Home have any way to change the type of a device? Alexa, for example, lets you change the type between a switch and a light.

Probably several ways to do this but if you’re looking for a quick and dirty way to do it then simply create a Google Home routine that can use a single phrase such as “Turn on/off Kitchen Lights” to execute various command(s) that you can define.

I’ve looked all over the place in google home and didn’t find a way to do it

The routine name would clash with the default command “turn off the kitchen lights” I suppose but I’ll give it a go. Thank you for the suggestion

If you’re going to go for a hack, I’d create a virtual light and sync it to the physical switch status using SmartLighting or WebCore, then add that to your Google Home Kitchen group.

1 Like

Remove the device from Google smartapp, add the word light to the name and then readd to Google smartapp. That worked for me before.