URL generates error


(Mike) #1

I have been using a Thingspeak Logger smart app for awhile but a few days ago I tried adding a new channel and I kept getting an error. From the logs it showed

org.apache.http.MalformedChunkCodingException: CRLF expected at end of chunk

The URL it sends is
http://api.thingspeak.com/channels/“channel ID”/feed.json?key=“Write Key”&results=0

Channel ID and Write key have been changed to protect the innocent.

This was from the line of code getting the channel info. From looking through the thingspeak documentation the URL the app is sending out seems okay, and it’s the same one it has been using for several months now, and working great.

I hard coded my device names in the app and got it working again. The URL it sends to update the individual channel data works fine. Anyone have an idea why this error might be occurring?


(Mike) #2

I figured it out if anyone is interested. Apparently things speak changed something and the URL needs to be HTTPS now.

It only ran that part of the code if the app was updated which I had not done in awhile, so it worked until I tried to add a new field. I thought I had already tried changing it to HTTPS once before and it gave me an error, but apparently not. Although I did change a couple of other things in the URL as well. The original has feed.json and the thingspeak docs say it should be feeds.json and key should be api_key. So maybe it was a combination of all those things that fixed it.

Didn’t feel like going back and testing the other changes.