Updates to the SmartThings Platform

Very true I’m sure. @Lars and other staff will no doubt be constrained by formal or informal rules on what they can say here. Whilst frustrating for us users, this is reasonable and understandable. It’s probably frustrating for Lars too, though he wouldn’t be able to say so of course :smirk:

I think we must appreciate the informal help we get and the nuggets of news. Like everyone else though, I long for more!

6 Likes

Have you seen a response where it was mentioned to bring the attention of the management? Or acknowledged the issue. - I saw for other subjects, but not for this.

I understand your point, and you are right. But it shouldn’t be handled like this.

3 Likes

Yes, you can. When you click the geolocation, there is slider between the name of location (on top of screen) and the map. You can use the slider to choose between 250m and 2000m.

When the Smartthings cloud goes away how will I be able to see and control my devices on my phone if I’m not on my local network?

Where did you get this info? Because that is not going away :slight_smile:

A large percentage of folks now use the ST app without a hub so it is all based in the cloud.

Oh, so what is going away? What was all that chatter about SmartApps and Device Handlers not being supported on the IDE soon?

Classic app is being retired. Groovy based device handlers and IDE will be phased out at some point in 2021. But the replacement device handlers will be in place before that occurs. Plus other new stuff coming!

2 Likes

OK, thank you.

I guess I got the idea that the Smartthings cloud is going away because of this entry at the very beginning of this thread:

The current Cloud-based system for monitoring Hub-connected devices will be replaced with a new service that runs locally on SmartThings hubs.

I too have repeatedly followed these steps @jkp and get the same result as @vdbg:

All works fine in Classic App but devices appear but don’t show presence and clicking on them does nothing. Head scratching time…

I have no clue. I had to reinstall 2 weeks ago after my life360 stopped working. I had to remove both the device and the smartapp and reinstall a fresh copy from the Classic app and it worked for me. I guess I was lucky

1 Like

We understand the frustration. As @JasonM said below, we’re working on a permanent fix that provides the type of selection and filtering the community is asking for. This fix requires a significant amount of dev effort though. We tried to ID near-term fixes that would provide this sort of functionality but none of them would have been done in time and they would have resulted in unacceptable compromises based on the feedback we received. The dev teams are working on as fast of a timeline as possible to get this out.

18 Likes

Same, mine was just ZUnused

Just a question on this, why wasn’t this done BEFORE you pushed the change in the app out? Was there a timeline crunch for the specific app?

This was something that caused havoc the first time around. Is no one left there that remembers that? Or was it even a consideration to keep the same functionality as the version it was replacing?

14 Likes

This is my frustration. I don’t get why we were forced to use the new Google Home migration when it’s not even ready yet. Now I have dozens of specific lights I didn’t want voice controlled turning on when I want other lights in the same room to turn on.

I had things working perfectly and now I’m looking at home automation alternatives.

12 Likes

As has been mentioned, if you create a “dummy” room to store those items you do not want turned on that works. Also, you may need to rename them if they have similar names. I did this the first time around and again when they removed the selection capability. I have moved on to another platform that has selection capability as this on top of the forced migration were the straws that broke the back for me.

3 Likes

This and Echo Speaks Lite would have been done in time if the timing of your decisions respected your engaged and dependent developer and user community. [Release] Echo Speaks v3 + Actions

I am truly appalled at how any company with such a well developed community of users would behave this way. I can only hope that this is a learning experience, the third time around.

11 Likes

A post was merged into an existing topic: Alternative Hubs