Updates to the SmartThings Platform

You seem to be inferring that the change of location mode to Away isn’t working. Have you considered the problem from the starting point that it is working?

Given the result is that the location mode is Home, I’d be looking at any other automations you may have that set the location mode to Home. For example, if you had an arrival automation that said if location mode is away and someone is home, the set location mode to home, that might instantly flip the mode back to Home.

I do not have any motion, or presence based automations, or scenes. Everything I’ve done has been either manually via the phone app, or A request via Alexa. Pretty much all I have is good morning, good night, enable, disable and they’re all requested. This is simply just a test routine to see if I could get the mode to change.

If I can figure out how to remigrate, then I think I’ll try that, and if not I think it’s time to move on…

Thanks

I found my problem and thanks to @orangebucket. His answer wasn’t exactly on target, but it was certainly in the ballpark and it got me to thinking. Apology now, this will be kind of a long post, but it may help someone else.

I migrated about a month ago. The routine and scene conversions were a little confusing but they were pretty much working, albeit a little on the slow side. The Alexa triggering ST was working pretty good, and the stuff within the ST platform was working as well. ST to Alexa with either virtual or physical contact switches were failing or taking upwards of an hour. On the other hand, the virtual momentary(button) switches were starting to be a crap shoot as to what the setting was.

I started having some really weird issues about two weeks after the @lars memo. I did find and solve one of my big issues today…not being able to set my STHM and or hub mode…see my prior post/example. I’d set it to away in an automation, and it “appeared” not to change. I could even set it manually, and it would change back.

Ok, I was using virtual buttons to trigger my different security settings, good morning, good night, arm, disarm, etc. What I found out, by process of elimination, was that somehow my automations were being triggered, without me touching any of the virtual buttons, but I think it was due to them? Also, it appears that the “disable” automation was always the last one to trigger, leaving the HUB/STHM in the “home/disarm” mode. The test scene as you can tell was very simple with no trigger being used that was in any of the normal scenes and automations. What I did finally see after trying to check it quickly, was that sometimes the setting would blink to AWAY, and then back to Home. As I told @orangebucket I have NO presence, motion, or timed automations. Everything was based on triggering a scene on Alexa or via the app to kick off the automation.

The fix was to go to a regular (2 function) virtual switch in the scene/automation trigger process. I set it on In the scene to trigger the automation and turn it off as the last action in the automation.

This works well with Alexa also as it can simply set an action to trigger the scene.

If ST can just get the ST to Alexa triggers to work, and in a timely manner I’ll be happy.

Again, sorry about the long post…hope it helps someone

TG

2 Likes

Thanks for the suggestion @philly33flyers though sadly it doesn’t work for me. I’ve tried a few different DTHs now, “Child Metering Switch” and “Fibaro Double Switch 2 - USB”. still just shows “Checking Status…” for both channels in the new app.

No, no, no, no, no…

We cannot feel this! Forced to make a choice? This is what forced to make a choice looks like…

Back in May when the new voice assistant integrations have been released we have raised our concerns, that users want to have control over the devices shared with any voice assistant. There was no reaction on that. Since the release @Lars is just ghosting anybody who dare to ask about the feature, what is on a personal level, is a really not kind behavior.
Just look around, and assess the situation. You are doing the same mistakes what the Dilbert comics are full of it. Here is one for example,

9d0edffb74904ee2e6b47a4f14b2117a

This morning, I tried to turn off all my lights by Google Home. It has turned off the 3 LIFX bulbs (directly connected), but not the other 30+ lights from SmartThings, as the old integration has been removed overnight. I am not saying, that you haven’t noticed us, I was listening for the past week that SmartThings is updating their systems on the 8th of September noon…
But you still haven’t got the same level of features what you have for years. What’s is the point of this kind of development?
I feel more and more, that you are just following the dumbest IT trends. Re-design the view, and later we will find out what have been missed. Most of the Mobile operators, banks does that with their apps, and they do piss off people. Have you ever had that experience? I did have it many times, like T-Mobile redesigned the UI, but forgot to add the feature to check your current balance, what was used by most of the users. Oops…
We feel here the same, day-by-day.
All these announced decisions triggered an exodus from SmartThings to many other platform, including Hubitat. And they are already have a good traction from this. Are you going to be the next Wink? Are you going to turn to be fully Samsung with the user experience attitude? That’s not going to really help you out…
What Samsung doesn’t understand, people are not changing their devices every two years, especially not a Home Automation system. If that’s the plan for further support, then please let us know and the last one will turn of the lights. If that’s the way forward, don’t be surprised when someone will have the great idea to deploy Tizen OS on the Hub as well, or being end up as the Artik project.

Please listen to your users, and see what’s is going on. Be proactive and not reactive. That doesn’t help anyone!

8 Likes

2 posts were merged into an existing topic: Alternative Hubs

Most likely, Lars isn’t “ghosting” anybody. Big companies have product managers and engineers. One designs and the other makes it happen. He probably isn’t the one making the design decisions.

4 Likes

Very true I’m sure. @Lars and other staff will no doubt be constrained by formal or informal rules on what they can say here. Whilst frustrating for us users, this is reasonable and understandable. It’s probably frustrating for Lars too, though he wouldn’t be able to say so of course :smirk:

I think we must appreciate the informal help we get and the nuggets of news. Like everyone else though, I long for more!

6 Likes

Have you seen a response where it was mentioned to bring the attention of the management? Or acknowledged the issue. - I saw for other subjects, but not for this.

I understand your point, and you are right. But it shouldn’t be handled like this.

3 Likes

Yes, you can. When you click the geolocation, there is slider between the name of location (on top of screen) and the map. You can use the slider to choose between 250m and 2000m.

When the Smartthings cloud goes away how will I be able to see and control my devices on my phone if I’m not on my local network?

Where did you get this info? Because that is not going away :slight_smile:

A large percentage of folks now use the ST app without a hub so it is all based in the cloud.

Oh, so what is going away? What was all that chatter about SmartApps and Device Handlers not being supported on the IDE soon?

Classic app is being retired. Groovy based device handlers and IDE will be phased out at some point in 2021. But the replacement device handlers will be in place before that occurs. Plus other new stuff coming!

2 Likes

OK, thank you.

I guess I got the idea that the Smartthings cloud is going away because of this entry at the very beginning of this thread:

The current Cloud-based system for monitoring Hub-connected devices will be replaced with a new service that runs locally on SmartThings hubs.

1 Like

I too have repeatedly followed these steps @jkp and get the same result as @vdbg:

All works fine in Classic App but devices appear but don’t show presence and clicking on them does nothing. Head scratching time…

I have no clue. I had to reinstall 2 weeks ago after my life360 stopped working. I had to remove both the device and the smartapp and reinstall a fresh copy from the Classic app and it worked for me. I guess I was lucky

1 Like

We understand the frustration. As @JasonM said below, we’re working on a permanent fix that provides the type of selection and filtering the community is asking for. This fix requires a significant amount of dev effort though. We tried to ID near-term fixes that would provide this sort of functionality but none of them would have been done in time and they would have resulted in unacceptable compromises based on the feedback we received. The dev teams are working on as fast of a timeline as possible to get this out.

18 Likes

Same, mine was just ZUnused

Just a question on this, why wasn’t this done BEFORE you pushed the change in the app out? Was there a timeline crunch for the specific app?

This was something that caused havoc the first time around. Is no one left there that remembers that? Or was it even a consideration to keep the same functionality as the version it was replacing?

15 Likes