[UPDATED] Osram Lightify RGBW A19/BR30 US version (HA) DTH

One possible option - The custom functions are stil there in that DTH, you just can’t ‘just hit a button’ (because you can’t see it) If you have Webcore installed the custom functions of the DTH should still work there - you can call .colorLoop from a piston. You could trigger that piston with a virtual switch or some other trigger… I think you can see where I’m going with that.

I’m not sure if anybody has done this, but I couldn’t get WebCore to work, and there was no publicly posted smartapp to handle Color Loop Mode for the OSRAM RGBW device handler.

So I created a Smart App to fill in the gap until the new Smartthings app brings back “tiles”

The Smart App features:

  • Multiple Bulb selection (Could not find a way to filter capabilities of OSRAM device handler, so any color changing bulb can be used, will crash if device handler not set to OSRAM!)
  • Set Brightness
  • Random Hue (Non random hue will reset to zero for every bulb, inversely random hue will pick a random number and set the hue for every bulb)
  • Pulse Enabling
  • Blink Enabling
  • Color Loop Enabling
  • Switch/Virtual Switch toggle (works well with virtual switch)
  • Toggle for switching back to white when off

I have two models of Zigbee bulbs currently, that both work well with the device handler. The generic “CMARS” Zigbee bulbs work perfectly, and Sengled bulbs work, but loop will not turn off unless a direct color mode change (Smart App setting to reset white fixes this).

I would have liked to be able to control settings via smart app too, maybe hook them to dimmers/virtual dimmers, but could not quickly find docs for changing these settings without modifying the device handler.

I was able to get webcore to work. I created a virtual switch for each light I wanted to control the color loop and referenced that in the code. However I do like the look of the smartapp. Will check that out too.

1 Like

I know this is a little off topic. But do you guys have problems. Like she you say turn the lights blue it does like does them all one by one. Like she. I used the Lightify hub i would say Alexa make the living room blue. Boon all would go blue at once. But now ever since i left that hub and went to smart things. All of my lights don’t act as one big group any more. I mean it works but it looks horrible.

I just switched them to the osram handler from zigbee lights to see if it would work better no luck.

I know the Lightify hub is good till august! But was hoping it wasn’t only me having this issue. I have reset the bulbs went back and fourth. Just want them to work together better instead of going one by one

It seems to work OK. I’m using Google home.

take a look at mine!!

yours seems to be working but hard to tel since they are not as close to each other. like in lightify app woudl say make living room blue. then boom all blue at once

I too have been using webCoRE to turn the loop on and off as well. I have a LED strip on the back of my TV which only loops when None of my Harmony activities are running. If there is a Harmony activity running, then it stops looping

When using the OSRAM RGBW driver, there are some settings exposed around color transition times etc. I wonder if you have different settings on different bulbs?

That’s just a function of how ST handles multiple devices v. other manufacturers. It’s not something you can change through a device handler. Search the forum for ‘popcorn effect’ You’ll see a lot of threads.

1 Like

looks like it does what do you have all yours set to?

that is horrible. you got any ideas of a better hub i had hubitat and returned it last year when i didnt know as much as i do now

From top to bottom: 2, 4, 2, 4, 5.
BTW. Changing the last one did change the speed of the color loop, so these do seem to have an effect per bulb. You will need to turn the bulb off and on for the settings to take effect.

Well, blandman, I’ve tried installing your modified device handler, and am probably overlooking something obvious, but when I follow the instructions and make a new device handler, publish to me, then pair with SmartThings, it comes in as “Sylvania Light.” Going into “Devices” “Edit device” I change the device type to OSRAM RGBW" and change Sylvania" to “Osram” but when I save, it all goes back to what it was. Data shows it’s an Osram Lightify A19, but when you click on the device in SmartThings, you can’t get to the various settings. The “three dots” menu allows only “edit” and "information, and the settings that I used to be able to get to are no longer offered.
…got a suggestion? I’m sure there’s something simple that I didn’t do.

Hey Ducko,

The groovy code I posted isn’t a device handler, it is a SmartApp. Revert back to the original Device Handler from OP, then install my groovy as a smart app, you should still have the settings on the device. Then configure the smart app and add the bulb.

Aarrgghh!. I just KNEW it was something dumb that I did (i.e. not follow the instructions).
Thanks a million. I’ll get right on it.
Duk

Okay. I’m having trouble with the “Revert back to the original Device Handler from OP” part. It keeps coming in as Sylvania. I must have clobbered something during my various attempts, because I recall it used to come in as an Osram device.

Then I noticed that there was no device handler in the list on api.smartthings.com, so I added a generic device handler (yes, I set “Location” before making changes and publishing and whatnot). It’s copyrighted 2015, so probably isn’t the latest code.

I can’t get your SmartApp to install. During “Add SmartApp”, when I hit “Done” it replies “We’re having trouble connecting. Check your network connection and try again.” As it stands, ST controls the lamp off/on, but that’s it. It doesn’t respond to any of the color manipulation controls, and there’s no way to enter the settings as used to be available previously.

Any idea what I could do? I’m thinking, install some other device handler, but I’m not sure which one.

…later…

Okay. I found an updated driver at https://github.com/gkl-sf/SmartThings/blob/master/osram-bulb-HA.groovy which I plugged in, in place of the older generic driver. It worked- - restored the settings option. I installed your SmartApp, fired it up, and everything works! Thanks. Christmas is saved! (…at least in the decorations department.) Many thanks for some excellent work.

Duk

With the retirement of the classic smartthings app, is it still possible to still set default color/level? Is webcore possible?