Updated : GE Link Bulbs - FINALLY getting ON status after manually turning on!

Sounds like a windows phone bug with “enum” preference type, especially if it’s working on Android. I’d contact support. If they can’t help quickly, maybe we can help you modify the device type code to hard code your preferences until they can.

i’m trying to make it so when i turn on/off my bedroom light from a non-ST wall switch that my ge bulbs can then use ifttt to turn on my other ge bulb in the room. I tried this code and it works only when i refreshed the ST iPhone app so this does not help for what i want to happen with my lights. My wife wants to walk in the room and just turn on the lights. Im just trying to get 2 lights to work from 1 wall switch. Is there anyway to get this to work? thanks for any help

thanks. This worked.

I think I understand what you’re trying to do. Unfortunately when these GE bulbs get turned off manually (via a non-ST switch or not the app) they do not send an “off” command to ST, and because of that you can’t trigger anything.

Is there a way to create a master switch that will just refresh the state of all the GE link bulbs? I’ve noticed that when hello home commands are run not all the bulbs always respond. When they don’t ST won’t pick pick up that they’re still on either unless I manually refresh state of each one… I’m using the v2 code as well btw! Thanks guys!

I just installed it myself, so I can’t comment on how well it works, but I think this is what you want:

1 Like

Hi there,

I’m new to SmartThings as of December.

I have a Hub, 9 GE Link bulbs, 2 SmartThings door sensors, a SmartThings Motion Detector, 1 SmartThings switch, 2 Aeon Labs Multisensors, a presence monitor, and three iPhones used as presence monitors.

I was having the problem described earlier in this thread: manually turning off the bulbs caused them to go out of sync with the status reported in the app. Additionally, I was having some reliability issues with the bulbs responding to commands. I found this thread and installed the v2 code and had to uninstall all the smart apps, then uninstall each bulb individually, then reinstall them and rebuild my apps.

This helped a lot with reliability, though still not up to 100%, and I also installed Pollster, which as I understand it, is required for the app to check the bulbs’ status on an interval.

This worked for a few days, but last night, the bulbs stopped responding to switches and mode changes as expected. The debug mode log shows nothing out of the ordinary, except “Socket not healthy,” but this is apparently normal? I tried restarting the hub to no avail.

Anyway, I’m pretty frustrated and wondering if anyone else has had this problem, and what they did about it. Perhaps I am misunderstanding the roll Pollster plays in this?

Starting to wonder if I should get rid of the GE bulbs and go for the officially supported TCP Connected bulbs instead…


Your issues may be related to this:

Some have cleared up issues by rebooting hubs but many of us still are seeing problems.


@beckwith and @niceindividual, I bet this has something to do with it as well:


I was impacted by this last night.

1 Like

Thank you @beckwith and @johnconstantelo. I’m glad I posted instead of trying to figure it out myself! I subscribed to the status updates via SMS. How often do you see these kinda crippling system problems?


I’ve tried pollster and from looking at the live logs there never seems to be no actual response from the GE Link Bulbs with the V2 indicating on or off, cause even after pollster has run when i go back and hit refresh it will then tell me the light was actually on. Anyone change it to refresh() instead of poll() ? i read someone that did do this earlier but can’t find if it worked well for them…

That’s strange because poll() and refresh() have the same zigbee commands (except refresh() calls poll() at the end of it’s command). I’ve seen poll() update the bulb status personally, but weirder things have happened.

Thankfully not a lot.

Okay. I bought a link bulb last night. Put it in a lamp and told the app to look for something and the light flashed and the bulb showed up. Set it up to come on at dusk and go off at 10:30 pm. (It was already dusk so it stayed on.) I came down this morning and it was still on. The ST app could not turn it off. Tapping the icon would just turn it from green to white, but nothing would happen with the light.

So, I found this topic, and loaded the device type linked above. But it still would not turn the light on or off. So, I played the on-off-on-off, etc until it dimmed and shot back to bright.

Then I deleted it from the things and went to add it again. It took a really long time to flash, but the light didn’t show up. I went away and came back later and there was an unconfigured “thing” on the plus sign. I tried associating it with the new device type, but it didn’t work.

I’ve tried removing it and re-adding it several times and it takes forever to flash, but the iPhone keeps spinning as if it didn’t find anything. It’s been spinning the whole time I’ve been typing this.

I just canceled the search and flipped around on the screens for a bit and the blue 1 just showed up on the plus sign and I have another “thing” that is not configured.

Anyone have any ideas?


@Todd_Whitehead I’ve been having a hell of a time with my GE Link bulbs, even with the updated code. I seem to be having a new problem every other night and I want to just get rid of them all at this point. I’m also having trouble with the official SmartThings outlet that came with my starter kit. The only things that’ve been reliable are the motion sensors.

I’ve read, perhaps somewhere in this thread, that the hub sends a command once and assumes it reached the device. This is apparent in the frequent failed commands. I think this is a shoddy design decision and reflects a rush to market. If that’s the operational model then I can’t imagine a way to get anywhere close to 100% reliability.

I’m disappointed.

I’ve had really good luck with my link light bulbs. I have 3 GE link bulbs and a ST motion sensor. Just out of curiosity how far away from your wifi router is your ST hub? I only ask because Zigbee is on an adjoining portion of the frequency spectrum to wifi. As such it is prone to interference from a wifi router.

I also am having no issues with my link bulbs. They are waaayyyyyyyyy more reliable than my hues. I have never had an issue with any of them turning on or off correctly. Mine are in lamps so they are always powered on for the most part.

Ok, this may be new. I have had a mix of GE Link and older TCP bulbs in my network. About three days ago, the TCP bulbs stopped working due to a new firmware patch that they sent out. I did what Smartthings told me to do to solve the problem, and it did… for about a day. I had (up until that point) nothing but good experiences with the GE Link bulbs, so I decided to bit the bullet and make my entire network GE LInk. Well… that lasted about a day also.

Now, Smartthings is active buggy with all of my devices. I had to exclude and reinstall my lock, which seems to have fixed that. My new GE Link bulbs are not responding now either (with no indication of problems in the UI or logs, Smartthings thinks everything is fine.) I tried the same remedy (Deleted and tried to add), but I cant get these bulbs to go back into pairing mode (or recognize that SmartThings is trying to pair). Now I am wondering if the new release on the 21st is munging things up. Anybody else having similar issues?

They are in the same (12x12) room. The last time I tried it, I moved them so they were about 3 feet apart. no dice…

What’s weird, is the first time, it seemed to pair perfectly, but then ST wouldn’t actually control it.

None of my devices were getting switched last night for several hours. The motion sensors would see motion but nothing was getting turned on. Then I received this notification from SmartThings:

Jan 29, 2015
Device Control Issues
Resolved - Issues with device control are now resolved. If you continue to experience problems, please email support@smartthings.com.
Jan 29, 21:59 EST
Identified - We’re investigating an issue impacting a small subset of users related to device control.
Jan 29, 21:23 EST

It’s frustrating trying to troubleshoot this stuff while there are so many factors that can effect performance, but I highly recommended subscribing to status.smartthings.com for updates. You’ll get a text when they are aware of an issue.