Updated device type for Everspring Flood (Utilitech Water Leak) Sensor

Just added 2 today. This is how it looks on mine. I had the cloud with the line through it until I tested the sensors. I am using the stock Everspring Flood Sensor. I got mine used and had to exclude before adding. I also had to close both lids before it worked.

Very strange. The only real difference I see in the screenshots are in the metrics transmitted section. Mine is showing:

  • Received Messages From Device: 0
  • Received Messages From Device (Duplicates): 0
    **Messages Transmitted to Device: 1
    **Messages Transmitted to Device (Failures): 1
  • Updated Time: 2020-11-29 3:38 PM EST

When I added I did the following:

  • went into the hub, selected Z-Wave utilities, then selected Z-Wave exclusion, pressed button on flood sensor 1 time and the app shows 1 device deleted, the sensor starts beeping and flashing slowly

  • went into app and added device, selected Everspring Water Leak Sensor, selected the hub and room for the device, on the screen that says to press link key 3 times in 1.5 seconds, did this and the get 3 beeps from sensor and the app tells me the sensor was successfully connected. I put the back mounting cover on the sensor and test the sensor for moisture. It beeps until sensor is removed from moisture. The device never shows the water sensor, other than the cloud with a line through it.

That’s the same procedure I followed. Idk what else you can try. Maybe redo the entire procedure but unplug the hub for 20 seconds before trying to add the sensor.

I recently purchased some more of these sensors on ebay and had the same issue connecting as you did with two of the sensors. I finally got them to work by going through all the steps you described while only about a foot from the ST Hub. Idk how far you were from the hub but being close to the hub helped me. Best of luck.

Thanks I tried in the location I want the sensor and sitting about 3 feet from the hub. I will get closer to the hub and see if that helps. I appreciate the update

No luck. put the sensor on top of the hib and tried all the steps several times but it failed. Tried pulling the batteries on the sensor and rebooting the hub, still nothing. What a pain.

I have the same issue with one of my Everspring water sensors. Battery report but not moisture sensor. Same technical gymnastics. Less hair after dealing with this numerous attempts till i get fed up and leave it for awhile.

Mine decided to stop working 2 days ago. Tried changing to this device type and lost water sensor as well. When it stopped working, it was using a different DTH (stock maybe?) but reported WET (what a freakout that was for a hot minute) and then when I checked, bone dry.

Something went bad with this in the samsung side I’m thinking. Before I changed to this DTH I at least had it indicating “wet”. Not I get battery and nothing else. Doesn’t do me any good so I guess it’s time to try some other DTHs?

Samsung is driving me away with everything that used to work that is starting to break.

And all the sudden it LIVES. I tried adding it about 12 more times and even worked with Smartthings support. They were still in the debugging phase while I was continuing to try to add and exclude the sensor. And then after one of the adds it started reporting moisture.

Not an easy sensor to add but it is working.


I had similar issues. My solution was to replace the batteries with brand new ones.

Same problem - IT’S THE BATTERIES!
Device showed “checking” & batteries = 100%
Not True.
NEW batteries solved the problem.
I even tested my original batteries with my old analog battery tester. The tester showed them well into the Green indicator! Not good enough!
Solved my issue while installing my new Aeotec hub. I was barking down the wrong tree…several different trees!

I have the same problem. Have tried deleting and adding the device multiple times. Tried new batteries. Tried setting it on the hub when deleting and adding. I tried resetting the Everspring device to factory defaults.

Device shows “checking” on main dashboard of new app. When go into the device itself, it always shows the water sensor with a cloud and a line through it and batteries at 100%.

My IDE device details looks like kajoyce’s display from Nov 2020.

Any suggestions at all?

Have you tried getting it wet? I had to do this before it would work