Updated device type for Everspring Flood (Utilitech Water Leak) Sensor

Thanks for this information. I’ve added the capability lines to the DTH and will install my hardware today or tomorrow.

I am using this device handler and my battery is showing 100%. Find it odd that it is still 100% because i have had the batteries in this device for about 1 1/2 years. Anyone else experience this?

Yup. I have had one for 2+ years now, and it says 90%. Unless you’re tripping this off all the time, battery life could be 2,3,4 or even 5 years depending upon usage.

1 Like

Wow, that’s awesome.

Thanks for the feedback. I thought there might of been something wrong with the device handler.

1 Like

I will also vouch that the batteries last forever on this device.

According to my battery replacement log for smart devices I’m running on the same batteries since 12/25/14!!

I test the device every 6 months and use SDV to be sure it’s online

1 Like

I must have jinxed myself. Just did my 6 month test - device worked but then the batteries died at 90%. (according to ST).

So long story short - like most devices - the battery thresholds are off. But this device has great battery life.

Final Count - 40 months on the original batteries

Is there way to turn off the beep when wet in this DTH? I’m not that familiar with how these DTH’s work so am looking for some help.

What I’m trying to do is use this sensor for a small water fountain to indicate if the fountain has water or is dry. I use webcore to then turn off the associated fountain pump power switch if dry. If wet, webcore turns on the switch.

I just want to turn off the sensor beeping when I refill the water since it will drive my neighbors crazy.

Looks like ST release a local device type “Everspring Flood Sensor”, has anyone tried switching over to that DTH?

I have been using the stock DH with 6 leak sensors. My wife has set off the ones behind the toilets while mopping. The sensors seem to work fine with the stock DH. Screen shot below:

1 Like

I use the local Everspring DTH for mine, which I’m using to tell me when the hot tub is full. It works flawlessly

1 Like

Anyone able to use the configure button? Nothing happens when I touch it. This is with the native DH.

All that does is send configuration commands to the device. You won’t see anything change in either of the mobile apps, and since there are no device preferences to change any zwave settings, you probably won’t see any change in behavior either.

1 Like

Thanks for the reply. Just wanted to make sure that I wasn’t missing out on something.

1 Like

I just dug up a few of these and wanted to get them in operation. I tried the Everspring configuration in ST and it got recognized as a “zwave device.” When I click on it, it’s nothing like the water sensor. It’s an On/Off switch with icons that represent an outlet.

I reset and tried again but it always comes back that way. Is there another way to get it to work correctly? I could use these water sensors in the house, if I could only get them recognized correctly in ST.

Like the past user I have come across one of these water sensors but unlike them I am using the new Smartthngs app.

I can get the sensor added based on some information in the community. They suggested adding them as Everspring Flood Sensors which allows me to see them in the app. The battery level shows but the water sensor does not as shown in the attached image.

Anyone have one of these sensors working with the new Smartthings app? What device handler are you using? Does the water sensor notification and battery level work properly?

I tried troubleshooting this in IDE but did not get any log information from the live logging from the device even though the device says it is online. I tried using the sample code from the above device handler at the beginning of this post but the results were the same as the out of the box device handler. I also tried to create a custom device handler from the Everspring Flood Sensor template and modified the checkInterval to 60s but there was still no logging.

Thanks for any help on the issue.

I use the Everspring Flood Sensors DH and it works good with the new app. Batteries in these last a long time. Mine are 3 or more years old.

Hi Paul. Are they Everspring Flood Sensors or Utilitech TST01-1 0422362? The ones I am trying to configure are Utilitech TST01-1 0422362.

Thanks

I have a Utilitech that is working fine in the new app with the Everspring Flood Sensor dh. Have you tried excluding the sensor then adding it back?

Don’t have the details, but they are the Utilitech sensors sold by Lowes to use with there Iris hubs.

Edit: Utilitech MODEL #ST812-2

Grrr I have tried excluding and re-adding several times but it still shows the same cloud with a line in it for the water sensor in the device. I know the water sensor is sensing moisture because I tested it in water and it beeps that there is moisture. Any suggestions for how to get this thing added and working properly? I would have tried the old app but it isn’t available any more.

Are you guys using the default handler for the Everspring Flood Sensor device type? I added some pics of what I am seeing in the app and in IDE.

Thanks

2020-11-29 14_00_31-Photo - Google Photos