Updated device type for Everspring Flood (Utilitech Water Leak) Sensor

Try excluding the device from iris and then use the exclude on st and then try to include it.

thanks, actually the issue is that i already got rid of the iris hub

but I was actually able to reset the leak sensor and pair it with the SmartThings Hub.

Seems to be working great now!

thanks again

1 Like

Awesome job! Thanks!! I had no battery readings before!

Has anyone tried extending the coverage area of these sensors by adding a long wire to the probe? I’m thinking use a 2 conductor wire and strip the insulation every foot or so. Then lay this long wire on the basement floor around base of my water heater, water softener, sump pit, sewage pump, etc…

Hi @kevin, someone did exactly that with an Ecolink open/close sensor by using the internal screw terminals and some type of wire strip. I just tried searching for the discussion, but I can’t find it. What you propose should work.

Maybe this thread will help

That’s it! Thanks @Jimxenus.

Just got an 2 Everspring Flood Sensors. After mounting it I tested to make sure it worked and still could connect to Z-Wave hub. I tested it by licking my fingers then placing the probe on my finger. It alerted and I cancelled it. But it still shows as wet even though it’s clearly not. It’s been 8 hours and still shows wet.

Can you test again and see if that gets it back in sync? How far away from the hub are you. Battery level good?

Brand new batteries. Flood sensor is in basement which is pretty far from the hub, but there is another Z-Wave Plus device in room right above it that has no issue connecting to hub. Going on 15 hours and still showing wet. I’ll try testing it again when I get home.

1 Like

I tested it again and it didn’t reset. I ended up taking the backing plate off so the button was exposed to reset it. That ended up working.

Glad that worked, but kind of a bummer you had to do that. Ironically, I
just replaced one of mine with the Lowes Iris Leak Detector. It’s Zigbee
and identical to the ST branded version, but it joined a Thing. That was
easily fixed by changing the DH in the IDE to SmartSense Moisture Sensor.
I like the smaller compact design compared to the Everspring (it still has
it’s pros too).

One thing I noticed when testing was that the LED was not turning on when it got wet. It beeped (not super loudly), but that was it.

-Scott

@tosa I have 4 of these running your code and they never seem to report battery. They all read 100% and one has been in use for a year plus. Tested and it still working but there is no way it’s still at 100%. Thoughts?

I can’t speak for @tosa, but I bet these devices don’t report actually battery levels so they can preserve as much battery as possible. According to the device’s documentation:

The Water Leak Detector is powered by 3x AA 1.5V alkaline batteries. When battery level drops to an
unacceptable level, the Detector will flash a red LED once every 30 seconds and report low battery
status to the Iris™ Smart Hub. Iris™ will notify you of the low battery status. When this occurs, the
batteries should be replaced as soon as possible.

Based on that description, ST will probably always show 100% until the battery drops to that level, and then there could be some type of notification. ST’s default device handler does have the check for low battery, as does the DH posted above.

It’s been a long time since I’ve looked at this since my SmartThings has been boxed up due to a move. But I’ve got it set back up, and here’s what I remember about this device… @johnconstantelo is right about the device conserving battery power and about it alerting on low battery level. However, the device can also respond to battery status query during its wake up notification. The goal of my handler was to be able to modify this wake up interval (e.g. set it to wake up even less often to conserve even more battery) and to report battery status during wake up notification. At the time I wrote it, I had tested both the Utilitech and Everspring versions of the device with various levels of depleted batteries. Both reported battery level, and both would update their wake up interval according to settings. However, some time after that, a hub firmware update seemed to break the wake up notification and response. And SmartThings said it was my code even though it had been working before the hub update. Alas, it was then that I boxed it up and never did figure it out.

But like I said, I’ve recently set it back up, so perhaps I should look at this again! :slight_smile: The time to respond to the device’s wake up notification is short, so back then I didn’t know if v1 hub latency was an issue – keep in mind back then it was not a v1 hub, just the hub because there was no v2 yet. :wink: I still only have the v1 hub, but presumably it now has newer firmware that perhaps behaves differently?

The one time the device does stay awake for an appreciable amount of time (min instead of msec) is right after power up. As an experiment, you might try pulling the batteries for a few seconds, then popping them back in to see if then the device reports a different (more depleted) battery level.

@tosa and @johnconstantelo Thanks gentlemen. I guess I will play around with them a little more.

1 Like

I’m having the same issue where it is showing wet - days after a test. It is clearly dry. I’ve taken the back off but I see no change. I can see the sensor is communicating in the logging. Any tips on what you did with the button to reset it?

See this thread, there are a few batches of defective electronics the cause the sensor to get “stuck”.

So, I finally got back to this device. One thing that’s always bugged me is not knowing if the device is “still out there”, short of going around and manually tripping the sensor (which I still do from time to time). Anyway, I made a couple quick mods to:

  1. report to the activity feed changes to the Wake Up Interval (i.e. when the device actually picks up and sets a User change to the Wake Up Interval in the device settings).

  2. Added an option to report to the activity feed each time the device Wakes Up. This is my way of being able to monitor that the device is “still out there” by just checking recent activity. I have made it an option in the device’s settings because if I don’t, then somebody will ask to be able to turn it off. :slight_smile:

  3. Added an option to always report the battery status, even if no change since the last report – for the “hey, is this thing really reporting battery level?” people. :wink: Should be the case that a change in battery level will still get reported to activity feed regardless of this setting (along with the typical low battery alarms). But with this option on, each time battery level is reported, it will go to the feed, even if it hasn’t changed since last report. So far my experience has been that batteries last a loooong time.

I’ve also taken a stab at this GitHub thing and have moved this device type to:

I’ve tested this on both Utilitech and Everspring branded sensors, and it seems to work ok. But since I do this only very part time, let me know if you find any problems with this handler.

3 Likes