SmartThings Community

[UPDATED 4/19/17] Hue B Smart (Smart and FAST Hue Lighting)

hue
smartapp_lighting
dth_lighting
scenes
groups

(www.smartukhome.co.uk) #670

What code are you using should be using this


#671

That is what I am using. I had anthor update for the handlers and it works now. Odd that it would not work unless I updated the code.


(www.smartukhome.co.uk) #672

Smartthings changed the way some functions worked on the 6th September we fixed it and updated Hue B Smart on the 9th


(Brandt) #673

I’ve been using this app for a long time but just tried to discover some new hue appliances. I can see everything work in the logs but nothing appears in the UI. I’m getting this error in the logs after it finds the bridge and devices.

b8d0cc57-4628-404b-8566-9eb06b00ed887:50:37 AM: errorjava.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Integer @line 276 (parse)

I updated from the tmleafs GitHub about 48 hours ago and it’s still failing.


#674

@infofiend Do you know what this error means? It is coming from the Hue B Smart app.

9:56:36 AM: error groovy.lang.GroovyRuntimeException: Ambiguous method overloading for method java.lang.Integer#div.
Cannot resolve which method to invoke for [null] due to overlapping prototypes between:
[class java.lang.Character]
[class java.lang.Number] @line 681 (updateStatus)


(Tony - SmartThings Unpublished Contributor ) #675

I’m sorry, I don’t. Have you updated to newest version?

Anthony Pastor


#676

Yes I have


(Richard Gregory) #677

I was having issues recently with hue devices not updating in SmartThings. I figured as Hue was working as expected everywhere else, I should remove and re-install hue b smart.

I have removed all device automations and attempted to delete my hub from the SmartApp, but get an error.

I see no device of that name, so cannot proceed. What next? Please help!

Thanks


(Richard Gregory) #678

Ok, I figure it was referring to the Hue bridge within webcore. Removed it and then I could delete!


(www.smartukhome.co.uk) #679

Didn’t need to remove it just needed to update to the latest version 1.8 released 2 days ago


(Richard Gregory) #680

Well, it appears I’ve been using the old repo from info_fiend. Is that why I’ve been having delay issues then?


(www.smartukhome.co.uk) #681

Surprised it even works


(Richard Gregory) #682

Actually, it was yours. Just the name says it was info_fiend!

Despite uninstalling and reinstalling, im still having delay issues. Any ideas?

Thanks


(www.smartukhome.co.uk) #683

What do you mean by delay issues

It’s the same name as I took over the project


(Richard Gregory) #684

SmartThings takes quite a while (>2 minutes) to update current hue light state.


(www.smartukhome.co.uk) #685

If you use 3rd party apps or devices outside SmartThings to control hue you will get delay of less than a 5 minutes can be changed to every minute but I wouldn’t recommend that


(Richard Gregory) #686

I just noticed over the last couple of days that my ActionTiles wasn’t updating. Tested direct in ST and found it wasn’t either. Now I’ve reinstalled, it just seems much slower than it was before?


(www.smartukhome.co.uk) #687

1.8 released a few days ago fixed issues