SmartThings Community

[UPDATED 4/19/17] Hue B Smart (Smart and FAST Hue Lighting)

I’ve been able to access my bridges again, except for one - I can get into the next menu after selecting the bridge, but there is nothing in it except the option ‘Delete bridge [IP] and devices’. The usual options to select bulbs, scenes, groups are missing. Help!

So I assume if I add this to SmartThings it will no longer work directly in the Hue App.

The Hue app will always work - this only connects SmartThings to the hue bridge. However, if you change the state of any light using the Hue app, those changes will not be synced with SmartThings.

Lost communication with my hub and the Hue hub.

11:25:06 AM: error java.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Integer @line 239 (parse)

It’s not refreshing devices and it won’t find new devices

I am trying to add two new blooms. It adds in the hue app but not Hue B smart app.

This was in the logs
9:21:51 PM: errorjava.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Integer @line 239 (parse

What code are you using should be using this

That is what I am using. I had anthor update for the handlers and it works now. Odd that it would not work unless I updated the code.

Smartthings changed the way some functions worked on the 6th September we fixed it and updated Hue B Smart on the 9th

1 Like

I’ve been using this app for a long time but just tried to discover some new hue appliances. I can see everything work in the logs but nothing appears in the UI. I’m getting this error in the logs after it finds the bridge and devices.

b8d0cc57-4628-404b-8566-9eb06b00ed887:50:37 AM: errorjava.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Integer @line 276 (parse)

I updated from the tmleafs GitHub about 48 hours ago and it’s still failing.

@infofiend Do you know what this error means? It is coming from the Hue B Smart app.

9:56:36 AM: error groovy.lang.GroovyRuntimeException: Ambiguous method overloading for method java.lang.Integer#div.
Cannot resolve which method to invoke for [null] due to overlapping prototypes between:
[class java.lang.Character]
[class java.lang.Number] @line 681 (updateStatus)

I’m sorry, I don’t. Have you updated to newest version?

Anthony Pastor

Yes I have

I was having issues recently with hue devices not updating in SmartThings. I figured as Hue was working as expected everywhere else, I should remove and re-install hue b smart.

I have removed all device automations and attempted to delete my hub from the SmartApp, but get an error.

I see no device of that name, so cannot proceed. What next? Please help!

Thanks

Ok, I figure it was referring to the Hue bridge within webcore. Removed it and then I could delete!

Didn’t need to remove it just needed to update to the latest version 1.8 released 2 days ago

Well, it appears I’ve been using the old repo from info_fiend. Is that why I’ve been having delay issues then?

Surprised it even works

Actually, it was yours. Just the name says it was info_fiend!

Despite uninstalling and reinstalling, im still having delay issues. Any ideas?

Thanks

What do you mean by delay issues

It’s the same name as I took over the project

SmartThings takes quite a while (>2 minutes) to update current hue light state.