[UPDATED 4/19/17] Hue B Smart (Smart and FAST Hue Lighting)

There is a DTH that you can search for to add the Hue motion directly to ST.

hmmm tried that and the lag is totally unusable for lights.

so it works brilliant as part of the hue setup, but I can’t get that information into ST. Is there any way to hack that process that is happening (it is activating a scene) to get it to work like a motion sensor? I’m not sure there is - because I can’t use the triggering ‘on’ of a scene, as that won’t tell me if motion is STILL happening. That can only tell me that motion did happen - and I’d have to send a crude timer.

It might have to go back to Amazon!

read thru the post, you can change the reporting time of the motion, it is currently set at 30 sec, I have changed mine to 10.

tmleafs,

Are you able to update the flash command to flash_on maybe? In WebCoRe, there’s an emulated command also called flash and would like to use the flash command on your device handler. WIth the same name, the flash command is not showing in WebCoRe

If the device provides a flash command (and publishes it with the command meta descriptor), then webCoRE should use that instead of the emulated flash - it should show device next to it.

That’s what I thought, thanks ady624. I updated the Device Handler manually for myself to get it to show:

Now flash_on is showing for me after I updated it. I mostly wanted to use the flash on the Device Handler because the Flash Off seems to work better to get the flashing to stop than when using the emulated command in WebCoRE. I was having problems getting the flashing to stop on the emulated version without having to pause and resume the piston which seemed to cause other issues.

I’ve been using this for a few months now and it’s really great. It’s so much better than the stock Hue device control. One problem I haven’t been able to resolve is related to the flash button. I have some Hue lux bulbs, and once they start flashing they won’t stop. I have to unplug the hub to get it to stop. Does anyone know of a fix for this behavior?

Are you using tmleafs DTH located here: https://github.com/tmleafs/Hue_B_Smart instead of the one on the top of this page?

Yes, that’s the one. It works fine with gen 1 Hue color bulbs, but not with the lux bulbs. It’s not like I really need the flash, but I figured it doesn’t hurt to ask.

I’m seeing this in my logs:

132ac1b8-8212-401a-b1a5-76be1f7d5d3c 10:43:41 AM: debug newHue = 86, newSat = 95
132ac1b8-8212-401a-b1a5-76be1f7d5d3c 10:43:41 AM: debug colorData from XY = [hue:0.862204689816314, saturation:0.9531930338779699]
132ac1b8-8212-401a-b1a5-76be1f7d5d3c 10:43:41 AM: debug HS from XY = [hue:0.862204689816314, saturation:0.9531930338779699]
132ac1b8-8212-401a-b1a5-76be1f7d5d3c 10:43:41 AM: debug colorData = [hue:0.862204689816314, saturation:0.9531930338779699]
132ac1b8-8212-401a-b1a5-76be1f7d5d3c 10:43:41 AM: trace getHSfromRGB ( 281.70547, 13.185779, 235.1903):
132ac1b8-8212-401a-b1a5-76be1f7d5d3c 10:43:41 AM: debug RGB colorData = [red:111.30403767104583, green:31.03983069107143, blue:103.23751673097796]
132ac1b8-8212-401a-b1a5-76be1f7d5d3c 10:43:41 AM: error groovy.lang.GroovyRuntimeException: Ambiguous method overloading for method java.lang.Integer#div.
Cannot resolve which method to invoke for [null] due to overlapping prototypes between:
[class java.lang.Character]
[class java.lang.Number] @ line 631

I’m on the latest code from git and my ST hub is version 18.20.

I’ve stumbled here looking for the best DTH to drive my Hue Color Ambiance BR30 RGBW without a hub (the bulb is paired directly to my ST hub). The single coolest feature for me would be, if possible, the ability to digitally specify colors I want (e.g. enter #FF0000 instead of using an analog slider).

Any DTH recommendations with that in mind? It isn’t quite clear to me if the options in this thread work without a hub (and/or what the penalties are).

What type of bulb is this?

this requires the hub,

Your have to make a DH that sets the colour in preferences so it would require 3 button presses, plus the typing of the colour code just to change the colour.

There would be ways with webcore to simply fly the colour change but it would be a complicated set up

is this single bulb or a groups of lux bulbs?

I have the problem with both the individual Lux bulbs and the Lux groups. Same behavior no matter how I add the light.

Fixed - Have updated the Lux Bulb and Lux Groups DHs

Awesome. Thanks! Works perfect!

I think it was one of my Blooms. I’ll test it again later this morning and find out for sure.

Ok, yeah, it’s one of my Blooms. Is there any data you need from me to help debug it?

tmleafs,

Any chance to look at my request above to rename flash to flash_on or something simliar?

This is so I could use the flash command in the DTH since WebCoRE also has an emulated flash command. I was able to fix it on my own and confirmed it works if it’s renamed in the DTH with WebCoRE.

I have the same issue. I tried the clean up with no avail.

I have a old bulb showing up with a mac of my hub when I’m on the discover section of the app. My hub adds to ST via the original app no issues but not this. I’m on the tmleaf branch too.

UPDATE: reset my hue hub to factory. Still happens. This has to be a ST issue. It’s really odd

HELP

@infofiend

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.