[UPDATE] IKEA Trådfri Bulb Device Type

If you buy the Ikea Dimmer Kit, is it possible to still use the original Dimmer remote after you sync the bulb with ST?

I tried it myself. As soon as I sync the bulb to ST, the remote loses the sync with the bulb and does not function at all. When I reset and reconnect the remote to the bulb, the bulb loses its sync with ST.

I don’t have Tradfri hub, but I wonder having one would help. I do like the design and functionality of the dimmer remote control, but I also want to control the bulb with my app. Any suggestion?

Hello and thanks for your great work.
However, seems like the hub is unable to find my bulbs. Any thoughts on that?

That’s not related to the device type handler, you need to reset the bulbs before trying to connect them. Reset is done by turning the bulb on and off six times then connect it to ST. After it’s connected it should be assigned the correct dth, if it can’t find one that fits it will be added and named “Thing”

Done tgat several times. No luck though.

Try asking in this thread, there’s more people there that might be able to help you.

Thank you for the hint. and pardon the late reply. I will start there and
see where it takes me.

Anyone here able to add Tradfri in Google Home and voice control the light thru GH ?
I’ve seen several people do it on youtube, but haven’t been able to.

I’m using an American Google Home and a Tradfri that I bought in Belgium, maybe that’s where the communication mishap is coming from ?

I’m able to Authorize my Tradfri in Google Home, but when I leave the Authorization screen and automatically get thrown back into the Google Home app I get a “Couldn’t retrieve the settings, check your connection” and under the linked services I DO get the “Smartthings / Samsung Connect” service, but it shows 0 devices.

I control my stuff with both Amazon Echo and Google Home and it works fine no matter what light it is(hue, trådfri, osram etc) check in the google SmartApp under “Automation” -> “SmartApps” in the SmartThings app, i have “Allow Google Assistant to access all devices and Routines” checked.

FYI you can control SmartThings with anything that has Google Assistant, not just Google Home, if you have an Android Phone with Google Assistant you can also use that one.

Also, Google Assistant might now understand that a specific light is in fact a light so in case you say “Turn off all light” it might not turn off, so fix that you can give the device a Nickname like “Bedroom ceiling light” instead of “Bedroom Ceiling” that you might have in SmartThings

After so many people telling me to check this I think this is my biggest issue.
I do not have such a checkbox as my SmartApp is not called “Google” , but “The Google Assistant” … it seems to be a very old app (version 1.0.15 (Jan/05/2017).
Every time I link my Smartthings service with my Google Home app I’m getting this “The Google Assistant” app installed … in stead of the “Google” - one that everyone seems to be getting.

The only “option” I have in the “The Google Assistant” app is “Tap to uninstall” … there is no checkbox to allow access devices and routines … (see screenshot)

Have you added a SmartApp manually in https://graph-eu01-euwest1.api.smartthings.com/ide/apps ?

I have not. How would I go about adding the Google app from that screen?

You don’t, i was just thinking if you had some 3rd party SmartApp there called Google Assistant.
have you tried this?

https://community.smartthings.com/t/the-google-assistant-replaced-by-google-smart-app/96276/6

I used my gf’s iPhone to link Smartthings with GH and I now have “Google” as my SmartApp, in stead of “The Google Asssistant”. Checked the “Allow Google Assistant to access all devices and Routines”. Still no Tradfri in my Google Home app.

Are we absolutely sure the Tradfri that I got in my Belgian IKEA can talk to the American Google Home? (same frequencies ?)

it’s not the device that talks with google home, it’s smartthings.
This is how it works.
Google Home asks SmartThings what devices it has and gets a list.
Google Home asks SmartThings to turn on device called X from what SmartThings said it had.
SmartThings tells device x to do something

This is not good for my bloodpressure… :slight_smile:

So there must be going something wrong with Google Home (USA) trying to communicate with Samsung Smarthub (UK) altho Lars from Smartthings assured me that this was not an issue.

So - to reiterate : I’m able to Authorize the Tradfri from Google Home (thu Chrome opening up) , but once back in the Google Home app I don’t get control over the Tradfri (my Samsung/Smartthings list shows 0 devices in GH App)

Sighhh

You have almost the same setup as i do, i have a Google Home from the states, SmartThings from UK and Trådfri bulbs from sweden and it works fine, i would unlink you account in the google home app, remove the Google SmartApp from the SmartThings app and start over

“Google Assistant” is the “old” smart app that was installed when you added home control to Google Assistant/Google Home.

It was replaced in August/September timeframe with “Google” and appears to be what has caused a lot of people issues. I went to the Samsung support page and had them remove it while I was chatting online. Then I had to unlink Smarthings, factory reset Google Home, clear data on the Google Home App, reinstall the Google Home(s) to the Google Home app See note, and then relink Smarthings in Google Home App.

Note, AFTER I did the factory reset, I had to go to “Devices” in the google home app and delete the “ghost instances” of the Google Home Devices under linked devices. This happened even though I named them the same names as before. Look at the bottom of the “devices” list (Google Home/Chromecast Devices not Home Automation devices). There will be a blue “Linked Devices” which when clicked on shows the ghost devices.

1 Like

A thousand times yes.
I already thought this was causing my issue a long time ago (having “The Google Assistant” in stead of just “Google” as Smart App). I just had no clue on how to push for “Google” only.

I did a Factory reset on my main Google Home device (not on the Google Home Mini I have in my bedroom) and then linked Smartthings again thru the iOS app this time (it might work when I give it a try on Android now too, but I’m kinda not too keen on unlinking again and trying that out. I’m currently just sitting here talking to my light after so many hours wasted on this issue :))

So: in short. This is what fixed it:

  • Factory reset Google Home by pushing that big ol button on the “back” of the device for a couple seconds.
  • Relinking SmartThings / Samsung Connect after that thru my girlfriend’s iPhone and now my Tradfri finally finally showed up in my Virtual and Other devices. (mind you: it still says “0 devices” under Linked Services in the Google Home App under “Manage Accounts” > “Linked Services: SmartThings/SamsungConnect”

How to check if you are in the same boat as I was:

  • After linking SmartThings/SamsungConnect in GoogleHome go back to Smartthings App and click on your Tradfri light and go to it’s SmartApps tab. If you see “The Google Assistant” there , it means you are in the same boat. I have it working now and it says “No Installed SmartApps” on that tab currently.
    When I click on “Automation” from the HP of Smartthings App it says “Google” under the SmartApps tab now.

Any plan for including the new 600 lm bulb which have different colors?