Update 1.4.1 Disrupted My Happy Home?


(Dave) #1

Not sure whether this is a direct correlation or mere coincidence, but our home is just not the same since the 1.4.1 update on 8/21. Since the update, the Sunrise/Sunset smart app no longer sets modes, so any automation controlled by a specific mode is not occurring because Day no longer turns into Night and vice versa.

Our garage door has also gone schizo and become hot tempered after the 1.4.1 update. We have a multi-sensor that reports the state of our garage door; the open/close magnet reports that status, while the accelerometer angle is used to report when the garage door has been open for more than 10 minutes. After the 1.4.1 update however, the open/closed status begins cycling through the two states when the garage door is still closed and the temperature in the garage tops 80F. About every minute we’ll get a push notification that the garage door is open, and a few seconds later it reports that the garage door is closed again. The cycle happens again in 1-5 minute intervals until the temperature drops below 80F. When I check the actual status of the sensor after the open notification, it always reports that the sensor is closed. The accelerometer has also become “sticky,” not changing value when the door is opened, so the 10 minute warning never triggers. The multi-sensor reports its battery level at 75%, so that doesn’t appear to be the problem.

The presence sensors we have in our cars are behaving somewhat better after 1.4.1. They now give erroneous arrival/departure notifications only once or twice a day instead of randomly throughout the day. Still not reliable enough to trust them to automatically open/close the garage door when either the car arrives/departs though.

Outside of the specific automation problems, SmartThings 1.4.1 for iOS takes a really long time to load now; probably 2-3x longer than previous versions. Custom images within the app often don’t load and take a really long time to refresh if they ever do at all. I’ve tried restarting the SmartThings Hub, but that didn’t help resolve any of these issues.

To the SmartThings crew: please let me know if there are any logs or anything else I can provide to help resolve these issues for the 1.4.2 update.

Thanks,
Dave


(Daniel) #2

Sunrise/Sunset stopped working for me too, recently. What’s strange is that it still sends the commands it’s supposed to send, just never switches modes.


(James) #3

I am also having issues with the Sunrise/Sunset app. It seems to work less than 50% of the time. Generally speaking, if I uninstall the app, then reinstall it, it will work properly at least once, maybe twice, and then it stops working altogether. If anyone figures out what’s going on, please share. I suppose I’ll put in a support ticket.


(Blake Westerdahl) #4

I’ll add my voice to the Sunrise/Sunset issues. The Sunset side has been working no problem, but it has missed the Sunrise side for the last three days.

Prior to this weekend, it has worked as expected for the past three weeks.


(Dave) #5

Likewise, my instance still sends the commands it’s supposed to, but it no longer changes modes. I’ve also never had any success using before/after settings for either sunrise or sunset. I would like to set it up so that it does it’s thing an hour before sunset, but if I use that setting, then it does nothing at all.

  • Dave

(Dave) #6

Here’s what my lock screen and SmartThings log look like when the garage door multi-sensor starts going haywire @ > 80F…

Multi-sensor playing havoc with lock screen notifications…

Multi-senor filling SmartThings log with false events…

  • Dave

(Coolcatiger) #7

I am experiencing all the issue mentioned in previous post. Looks like lot of things broke…


(James) #8

Blake nailed the description of the issue I’m having with Sunrise/Sunset. The “Sunset” portion of the app works just fine, but the “Sunrise” portion never seems to work at all.


(Paul K) #9

+1 Sunrise/Sunset is failing on me with a nice chain of other things because of it. I was just coming on here to look at the example code for Sunrise/Sunset. In the simulator it seems to work somewhat ok. I also had the Smartthings service disappear on me last night when I went to go to bed.

Walking around the house turning lights off I had to wonder, exactly WHY do I want a cloud service for my home automation? People with local control are making me a little Verde with envy…


(Coolcatiger) #10
People with local control are making me a little Verde with envy…

I absolutely agree. I hope ST builds local control when on local wifi.

The Filtrete wifi thermostat has similar functionality - when i am on home wifi, the app says it is directly communicating with thermostat while from outside it communicates through cloud.

I like GUI of ST but miss local control of Verde…


(James) #11

+1 on local control. I feel like a dummy that I bought into ST without even knowing it was 100% cloud-based! Now I can only hope that local control comes out sooner rather than later; I’m pretty sure they’ve mentioned that a future firmware update will enable that functionality.


(Dave) #12

Here in CA, only my smart apps stopped working last night. I could still control individual devices from the SmartThings app and presence change notifications still worked, but none of the automation worked. I’m not sure how long they were out because I didn’t notice anything was wrong until it started to get dark and none of my automated lights were coming on. Functionality resumed about an hour later. Weird and frustrating.

  • Dave

(Dan Lieberman) #13

@digitalnative, @drmcclin, @jimjordan777, @surajt, @bleifrei, @trotsky40 – So we believe that the Sunrise/Sunset issue has been resolved. There was an issue introduced by a small change in the platform in last week’s production release that caused the mode change logic in the Sunrise/Sunset SmartApp to fail. This has just been fixed and published, and the engineering team has done some light testing. If you continue to have problems with Sunrise/Sunset, please email support@smartthings.com so that we can track the issue.

Thing brings me to my next point - one of the things that we’ve been asked for by several of you is more transparency around platform issues as they occur. We are in the process of implementing an issue tracking system. In the short term, it will mean that we’ll have better communication internally so that we can coordinate how we notify you about known issues (including outages and inconsistencies) as they occur, and as they are resolved. Longer term, it will help us get to a more-automated process like a system health dashboard.

Thanks,
-d


(Dave) #14

Excellent! Thanks Dan. Regarding support@smartthings.com, I will use it as you ask, but if you’ll allow some constructive criticism; it has been a black hole when I’ve submitted issues there in the past. Stuff goes in and nothing ever seems to come out. It would make for a better customer experience if we would at the very least get an automated response with a case number. I know you guys are still putting together the company and there are probably a ton of competing priorities, but I wanted to mention it in case it’s not currently one of those priorities.

Thanks,
Dave


(Dan Lieberman) #15

@digitalnative – How long ago did you send an email to support@smartthings.com? For some time now, all emails sent to support@smartthings.com should automatically open a ticket in our support ticketing system and respond automatically with the ticket number.


(Dave) #16

Dan - Shortly after I received my Kickstarter bundle, which makes it late May or early June. I think I was asking about the Alfred and IFTTT integrations, and then I tried again a bit later on a different topic. Last night, when all my installed smart apps stopped executing and my automation stopped, I tried using the “Talk to us” popup at https://smartthings.zendesk.com/home (~7:30-8pm PST), and also got no response. But everything started working again within the hour, so maybe somebody saw the message? At any rate, at least in my experience, support response has been null (except with you here in the forums of course). I’m happy to hear that the ticket tracking system is now in operation though. I’ll certainly give it a try if Sunrise/Sunset continues to be problematic.

Thanks,

  • Dave

(Cory S) #17

Interesting. I have always gotten a quick response from the support email address.


(James) #18

I’ll chime in on this. I run support for a software company, and we use Zendesk (same as ST). Every once in awhile, our automated Zendesk replies will get spam filtered on the customer end, and then the customer doesn’t realize we’re trying to communicate with them. I know that’s a pretty basic suggestion for relatively advanced users in the forum, but I’d check the old spam / junk filters for the ST support emails. I submitted a ticket about this issue and got both the automated reply and a human reply on the ticket. Of course, I haven’t gotten an update on the ticket, though the answer has been posted to the forum, so that’s kind-of interesting. But at least I can verify that the support system exists and is working for me.


(James) #19

No one mentioned this, and maybe it’s a dumb question, but do we have to “update” the Sunrise/Sunset SmartApp in order for it to be fixed in our individual accounts?


(James) #20

Update: The person handling my support ticket confirmed that no update was necessary and that the SmartApp should just start working now. Lo and behold, the “Sunrise” commands worked perfectly this morning. Hope everyone else is having a similar positive result.