Unable To Synch Ecobee SmartThermostat w/ Voice Control + SmartThings

I feel like it shouldn’t be this difficult but for whatever reason I’m unable to link my Ecobee Thermostat successfully with SmartThings. I set up my Ecobee (it functions fine both manually via the thermostat itself and via the Ecobee app) but when I try linking it to SmartThings, even though it adds the device, there is no functionality and it’s clearly not linked properly. In the images I attached to this post SmartThings doesn’t display the thermostat’s heat, humidity, or any other functional information and you can’t control anything. I tried deleting the device and starting over again, but the results are always the same.

Anyone have any idea what I’m doing wrong?

Deleting the device or removing the integration?

If you only tried deleting the device, go to Menu (lower right of the screen) click on settings (cog in the upper right) and open linked services. Remove the ecobee integration which will also remove any ecobee devices.

Then try adding it back to see if you get better results.

I agree, you should delete the whole integration and start again. It looks like this in the US.