Unable to setup new Meross Integration

I’ve attempted for the past few days to integrate my meross account into my smartthings account. However in the ST app whenever I go through Add Device → Partner devices → Meross → Next
I either:

  • Get stuck in a loading loop that takes me back to the Meross screen to hit “next”
  • The app crashes

Have attempted to clear cache/data as well as reinstalling the smartthings app, but the result remains the same.
This is on a Samsung S21 Ultra with Smartthings app version 1.8.05.24 on Android.

Anyone else recently integrated their meross account into smartthings, or experienced the issues above?

What country are you in?

Located in Australia

I was having the same issue earlier in the week, on iOS but it worked eventually after around 5 attempts

Thanks Jeff. Fortunately I have a spare iOS device and it worked straight away on the iOS ST app.
Not an ideal solution going forward if android remains broken but at least it’s working for me now.

I’ve reported the android issue to Samsung via the smartthings app.