Unable to set the device image, please try again

rooms
devices
images

(Robin) #1

Is anyone else getting this error when trying to set a device image?

Same tweaked device handlers (canChangeBackground: true) that I’ve always used for changing the images, worked fine until today. Even the ones I set previously won’t change now!

I’m not on the new firmware yet, latest ST app.

Same issue with the arrival sensors that have the image option (instead of icon) by default.


An Unexpected Error Occurred in Assigning Photos To Rooms
(might be my fake name?) #2

How do you get to the set device image PAGE? All I have is update icon.


(Robin) #3

(Robin) #4

I’m getting the same result on iOS and android, and with stock arrival sensor DH.

Anyone else having this issue?

Can someone try changing the image on an arrival sensor please?


#5

Same for me on 2 different devices, it’s been happening for about 4-5 days now. Logs seem to indicate a 500 error on the api call, I assume something is broken server side. Also it’s any image upload so it will error on rooms too.


(Robin) #6

@faze

Thank you, was starting to think it was just me!!

@Aaron @Brad_ST @slagle @Tyler

Any thoughts on this image upload error?


(Sam G) #7

Nice find. Had no idea this could be done. Anxious when this is fixed so I can try it.


(Robin) #8

It’s formally documented, and should be officially supported as it’s used for the official arrival sensor device handler.

I’ll raise a support ticket at some point tomorrow.

http://docs.smartthings.com/en/latest/ref-docs/device-handler-ref.html


(Sam G) #9

Ironic. I find a cool feature & I can’t use it lol
BTW, IOS app allowed me to select new image but doesn’t apply/retain after saving.


(Robin) #10

@Tyler

Would you mind looking at this one for me?

I’ve reported it to support under ticket #335706 but no resolution yet.

Another one of those tripped over Ethernet cables me thinks!


(Brad) #11

Are any of you having issues not in the UK? We are tracking an issue with saving images for UK users. I think (hope) this will be a quick fix once we get the right :eye:s on it.

You’re welcome to shoot a message to support and they can track/follow-up there or I’ll try to remember to update here. :smiley:


(Sam G) #12

North America here & app will not use/save selected images. I will send support a message tomorrow.


(Robin) #13

Please reference my ticket noted above.


(Robin) #14

Thanks @Brad_ST

After a bit of back and forth and additional logging placed on my account, response from Support:

“We have created a known issue ticket for this issue. At this time we do not have a timetable for when a fix will be released. We will notify you as soon as we have a resolution for this issue.”


(Brad) #15

Yep, I found your ticket. Sorry there was so much back and forth. I’ll work with the team to try to improve that.

We also do have some eyes on this issue this morning and I think we have a root cause, which could also impact North America. @rxsamg


(Luke - Backend Engineer) #16

The issue that we have found would only affect users in our europe shard. @rxsamg could you PM your email and shard if you are experiencing issue in our north american shards


(Robin) #17

@Brad_ST

Oh, I wasn’t moaning about the back and forth, all necessary questions in the right sequence to diagnose and test the problem.

Jim in support was clear and informative and responses were nice a quick!

Glad it’s being looked into so quickly… Thank You!


(Sam G) #18

@gausnes PM sent thx


(Sam G) #19

@RobinWinbourne did you hear anything back? I never opened a ticket but instead was PM’ing support. I’m being told support for the functionality may have been pulled. It is working for me on presence sensors only, not any DTH with the code above mentioned.


(Robin) #20

I’m being told a fix is in the pipeline for U.K. Users, it’s not working for any devices right now including stock arrival sensors.