Unable to set Region for Location (Pin in Map)


(Vladimir Amarante) #1

Hi there,

I’m unable to define my Location in the map. I wanted to do it for mobile presence purposes.

Here is what I did:
-> Add a Thing, Coming and Going, Mobile Phone, Connect Now:

Warning! In order for mobile presence to work you must first setup a region around your location.
-> OK

So here what I did next:
-> Menu, Gear icon near location name, click on the map “Tap to set where home is on the map, so things can happen when you come an go.”

  • Two screens with instructions come, OK got it.
    -> Map displays my location (blue dot showing gps location and Red pin with radius around it.
    -> SAVE
    -> DONE

Then I retry adding the Mobile Phone as a presence sensor and the same error appears “In order for mobile presence to work you must first setup a region around your location.”

If I go back to the Gear icon, the location is gone.

What is going on?

Thanks!


(Vladimir Amarante) #2

RESOLVED!

Changed my iPhone Region Format to United States.
iPhone iOS Settings > General > Language & Region > Region: Make sure it is United States, Advanced: Make sure Automatic is On.

Probably when you set a location region (drop the pin, geofence etc) the SmartThings App will get the Coordinates, but since my number format was not United States, the number format for the coordinate was probably generated with a comma not a dot, due to the other Region Format I was using in iOS.

Thx


(Dimitris) #3

I am facing exactly the same issue but the change of region does not work for me. I am located in United Kingdom. I’ve tried changing it to United States too and didn’t see any difference, i.e. the location I try to set is not saved, therefore I cannot add my iphone as a presence sensor. Do you think there is anything else I could try?


(Vladimir Amarante) #4

I’ve suggested United States Region format because my ST is US version.

Besides the steps I described above, I’ve turned the iPhone off after changing the region format, then turned it on, connected to my Wifi, opened the ST App and then set the region…

Today I noticed that besides my iPhone is working fine, my wife’s isn’t. The ST App on her iPhone gives me the same error message, meaning that ST App doesn’t leverage the Region/Pin I’ve set before in my Phone. So I understand it stores the coordinates etc locally in the phone, not in the Hub or not in their site. I’ll try the same steps in her phone soon.


(Dimitris) #5

Many thanks for the reply.
I’ve actually got the same problem as you - my iphone works fine but my wife’s doesn’t. I understand the setting of the location is per device, although all other home attributes (such as name, temperature scale etc) are set once and applied to all devices (phones).
I’ve followed the exact same steps when configuring her iphone but for some reason the configuration of the location always gets lost - even after restarting the iphone and completely reinstalling the ST app.


(Israel Munoz) #6

Took me forever to fix it until I found your post. Thanks!


(jfgilbert@hotmail.com) #7

Same thing for me here… works fine on my IPhone but even removing the app and restarting my wife’s IPhone and reinstalling the app, it does not work !! :frowning:


(Peter) #8

having the same problem overhere that i’m not able to save my location on the map :frowning:. Also tried setting my location to USA without any help. Anyone any ideas?


(Marcelo Liberato) #9

Having the same problem. Solved by changing her language from Brazilian Portuguese to English.

It is probably a bug with number formatting, as Brazilian formatting uses comma as decimal separator while US English uses dot.


#10

Having the same problem. This should be a easy bug to fix guys?