Unable to save any SmartApp configs on mobile (iOS)


(IrlStu) #1

Hello folks!

Long time user of ST but this is the first real issue that has me stumped - hoping you can help!

I’m currently trying to configure ST and HomeKit integration. I’ve installed the JSON API SmartApp and published it. However when I go into it and make any changes and click save… the changes are lost. When I go back into the SmartApp they have been reset.

Odd behaviour I’ve noticed: the app displays its app_id and every time I make a change the app_id will change. On the web UI when I go into My Locations -> smartapps and scroll down the bottom… I see multiple versions of the SmartApp. Each one will have the config I changed. Screenshot attached.

It seems that every time I save a config it re-created a new version of the app.

I’ve tried to delete all SmartApps, log all users out and reset things as much as I could… no joy.! I’ve also installed other SmartApps and I get the same behaviour.

Any help would be really appreciated!


(jkp) #2

Try logging into IDE with an incognito/private tab in your browser.


(IrlStu) #3

Thanks @jkp - just tried that. Opened incognito window, created new SmartApp… but same issue. No settings were saved and app_id keeps changing every time :frowning:


(IrlStu) #4

Ok, looks like its a know issue with the app in particular: https://github.com/pdlove/homebridge-smartthings/issues/243

It didn’t help that the other app I tested with was a fork and had the same know issue!