Unable to Login for EcoBee3 using Version 3.4.3 Device and 2013-08-07 MyEcobeeInit from Yves Racine

I was able to follow the directions (from https://github.com/yracine/device-type.myecobee), or at least I think that I was doing so, up to the point of logging into the EcoBee service to connect the thermostat but no login prompt seems to appear. I turned off the popup blocker in IE and also tried Chrome but neither produced a login prompt.

I am a new SmartThings user and this is the first thing I have done with the hub other than setting up a couple of simple routines and assigning them to an action, so it is quite possible that I missed something that should have been done.

Any assistance is appreciated.

Taking a stab here, as I do not own the device.

Please confirm that you have done the following:

Make sure that enable OAuth in Smartapp is active

Goto app settings (top right corner),
Click on Oauth (middle of the page), and enable OAuth in Smart app
Hit “Update” at the bottom

It is active and has a Client ID and Secret but not a Display Name or Link (I did have to click the enable button when I first set it up, as per the directions, but it has been there since).

You can use the “@” symbol to tag people in this forum. Yves is very active and will likely respond to help you out. @yvesracine

Hi @Paul77M, to execute MyEcobeeInit, you need to do it from the ST app (running on your mobile device), not the IE or chrome browser.

Please follow the detailed steps at

There is also a troubleshooting section under

http://thingsthataresmart.wiki/index.php?title=My_Ecobee_Device#Troubleshooting

Regards.

EDIT: I just tested MyEcobeeInit and it did create the device w/o any issues.

@yvesracine

I did also look in the app but I do not see a plus sign (or any other way of adding the smart app) in the UI. I do not know if the application has changed since the directions were written or if I am just in the wrong place in the app. The app is running on an Android phone.

Again, I appreciate any help that you may be able to provide.

Hi @Paul77M, as specified in the readme (step 3):


  1. Execute My ecobee Init

From your phone or tablet, within the smartThings app and on the main screen, click on ‘+’ at the bottom, under SmartApps, scroll down to My Apps, execute My ecobee Init

If you have upgraded to the new UI, click on the Smartapps link in the upper section of any of the following screens: Home & Marketspace, and then MyApps (last item in the list).

Regards.

@yvesracine, thank you. I actually just figured it out while trying to deploy my first smart app of my own to the device. Thank you very much and sorry for the trouble from my missing that wording.

Please support the developer with a donation!

1 Like

Hi, please take note of the following thread about My ecobee Device handler (and its service manager):

Regards.

I was just about to ask about that (or very similar). Thanks @yvesracine.