Unable to add/find multiple devices (Sengland, Wemo, Google)

Hi Community - I’m at a loss and hoping someone out there can help.

I have a SmartThings 3rd Generation Hub (I’m US Based )and am having trouble adding/finding a number of devices in my home. I’m unable to add:

  • Sengled Lightstrip (Model W1G-N83)

  • Wemo Dimmer Switch

  • Google Nest Thermostat

I have a number of other items that have added successfully such as Wemo plugs, regular Wemo lightswitch and my Ring Doorbell. My Hub is connected to my Verizon Fios router wirelessly after having been connected via ethernet and still not working.

With the Sengland light and Wemo Dimmer, I’ve tried multiple times to add each one manually (adding device by Brand) and nothing I do works. When I’ve tried to add the Google Nest (adding by brand), I’m routed to Google to allow access (which makes sense) and then I’m returned back to device page and it’s blank. Both the light strip and dimmer is found by Alexa and controlled by it as well.

I can’t seem to find any information on where to go from here and appreciate any and all thoughts. Thanks in advance!

First rule of home automation: “the model number matters.“ So you’re just going to have to work each device as a different problem, particularly since they are different protocols.

Next, we do have to ask what country you are in, as some integrations are region locked.

So let’s start with the sengled light strip because It is a Zigbee device and the pairing instructions will be the same for all regions since it connects directly to the hub.

Begin by resetting the device to factory settings. The following article from the manufacturer tells you how to do that. It’s going to talk about the Sengled gateway, but you are not going to use that, you are using the smartthings hub instead of the Sengled gateway.

Once you have followed those instructions and seen the correct color pattern flash, then unplug the strip for 30 seconds.

Now plug it back in and go through the add a device process in the smartthings app. Hopefully it will work this time.

I believe @HA_fanatic has some of these devices and might be able to say more.

1 Like

for the nest thermostat, i posted a response to your post in the nest thread :slight_smile:

1 Like

The WeMo dimmer switch is going to be tricky. It is not officially integrated with smartthings, although some other Wemo devices are. Again, “the model number matters.“

There is a community work around that some people have been successful with it, but it does require installing custom code, it’s a little tricky, and some people have said they had to try it multiple times before it worked. So I don’t know if you want to go to all that trouble or if you want to switch to a different brand that works better with smartthings. (Meross is a good WiFi switch available in many regions and has a good integration with smartthings for most of their models. It also typically costS less than WeMo. :wink:)

If you do want to try to get a Wemo dimmer to work, see the following thread:

Wemo Dimmer Switch

And if you’ve never used custom code with smartthings, here’s the FAQ for that. The topic title is a clickable link.

Thanks @JDRoberts and @jkp for your quick responses so far.

For the Sengled Lighstrip, the model is W1G-N83 and I’m in the US. I’ve reset/rebooted the lights a dozen or so times already an still no luck. It’s found by the Sengled app after each reset but never by SmartThings.

I’ll try all the stuff for the Next. I’ve deleted the SmartThings app a few times but I’ll try all the rest.

And I’ll read through all the dimmer options. When searching by brand and then Wemo, there is an option for dimmer so I assumed it would just work, like the rest of the light switches (I have to search for the model number), but it looks like you gave ma a lot to work with so I’ll be trying that out in a little while.

I wanted to at least get a thank you in to both of you for trying to help.

1 Like

@javajay looks like you are in good hands and got your answers. Sengled needs to be reset and connected directly to SmartThings, before Alexa can find them. A Zigbee device can only be connected to one controller. So if you connected the strip(s) to Alexa directly via Alexa Zigbee radio (or Sengled hub) you need to power off that controller, then reset the strip(s) and run discovery from SmartThings.

1 Like

Shoot! :face_with_hand_over_mouth:

The model number matters.

That’s one of Sengled’s new Wi-Fi models, not a Zigbee model at all. I don’t believe those are compatible with smartthings yet Unless you can do it with a cloud to cloud integration.

Try opening the smartthings app, choosing the + in the upper right, choosing add a device, look by brand, choose Sengled, and then when you get to a page like this

Choose “sengled WiFi bulbs”.

That will walk you through the process of creating the cloud to cloud connection and it might find your light strip.

The device that just says “smart light strip“ under “supported devices” in the screenshot is not the model that you have, that’s the Zigbee model. That’s why you’re going to choose the Wi-Fi bulbs instead.

Good luck, let us know if it works!

1 Like

Wanted to report back that two out of three are now working. Nest and Sengland both work! I’ll be working on the Wemo dimmer later today.

Thanks everyone! Digging this community!

1 Like