[UK] Nest Thermostat Device Type

Cheers mate, re-read the instructions and I chose Nest Thermostat instead of Nest. It seems setup ok now.

2 Likes

Hello, I’ve just installed a 3rd Gen Nest and followed the instructions to add to my SmartThings hub. It shows up under ‘things’ on my iOS app but when I tap on Nest in the list the app instantly crashes. I get a flash of the Nest controls (albeit a messed up version of it) before it crashes out.

Under the Device List, it seems to be communicating with the hub okay. It’s displaying values next to the temperature, humidity etc. I just can’t get the iOS app to work.

Any ideas?

Same here unfortunately, I saw a couple of other threads mentioning this in passing - perhaps its a “thing”. Sad times.

Do you mean that it no longer works? Surely one of the clever coders on here can fix that?

I wouldn’t necessarily go that far, but it seems that the iOS app currently quits when you try to view the Nest device.

As a followup here, we’ve managed to get this going under a separate thread.
Please see …

Awesome. I think I understand what’s happened - setPresence has been changed to setNestPresence in the code. I’ll just do a find/replace on my code and this should fix the issue for iOS users.

One thing I’ve noticed that has stopped working (for me at least) is the polling. I can’t figure out why…

Thanks… although my code was set to setPresence already but still doesn’t work. Is yours now working and not crashing out when you try to access it via SmartThings?

The code I’m using is
/**

Is this the version you’re using too?

Sorry, my reply might have been a bit misleading. I haven’t actually got around to change my devicetype on github yet!

No worries. I just fixed it based on the link @jamespreedy sent above.

Basically I did this…

I replaced ‘presence’ with ‘nestPresence’ - note the single quotes were typed.
and presence" with nestPresence" - note the double quote was typed.

Thanks to @dmw999

I have it working however the temperature read is in Fahrenheit and not C? How can I change this

Anyone notice a blank event (which according to logs is thermostatFanMode) every 10 mins with no data? Want to shortcut me looking at the code to hide this in my activity feed and see if anyone else has hidden them.

Are you using my deviceType from above?
I don’t have these notifications, and I’m pretty sure I removed the thermostatFanMode since the UK doesn’t use this.

yes i am. I changed via the IDE the device type. I have the new screen. I wonder if I delete the device and add it again.

Been using this for a while now, works great, except the polling, anyone else experience that?

I can’t get polling working. I have no idea why it stopped working as it all seems to be enabled and configured correctly.

Hopefully another dev can take a quick look to see whats going wrong

Very new Smartthings user here, only bought my kit at the weekend but I already had Nest G3. Got the original code working yesterday and then started messing with the code tonight to take out the non UK stuff but just found this code. Pasted it in and it works a treat, thanks :slightly_smiling: Very happy and thank you for your efforts.

Quick question, is it possible to set the Nest to Away as part of the ‘Goodbye’ routine?

Hi All.

I’ve purchased and installed 2 3rd gen nests and would now like to add them ST.

I just have 2 questions if anybody could help?.

  1. If I use the device type in this thread, can my nest also be used as a presence sensor?. I’ve read somewhere before this is not exposed in the API however one of its config settings is presence?.

  2. Will this device type continue to poll or is there still an issue with polling?. Can’t see a really valid use for my setup if ST is not reporting temp for me without needing to refresh.

Thanks in advance guys.

It can’t be used as a presence sensor unfortunately. I still cannot figure out for the life of me why this doesn’t poll correctly either.

I’m hoping a more seasoned developer can take a look and solve it

EDIT: Seems like polling is an issue across the board…

Have you tried:

3 Likes