Two Fibaro Buttons just suddenly stopped working


(Ron) #1

I have two fibaro buttons which have often given me a little trouble. For example I recently posted that they wouldn’t work until I opened the ide. But now they have stopped working at all.

When I press them while watching the live log I see activity but the button pressed or button held events never come in. I get “woke” and “battery status” events only.

I am using my own custom device handler which is a modified version of the @AdamV version but it has worked fine until about a week ago.

Is anyone else having issues with Fibaro Buttons?

I contacted Fibaro Support and they said I needed to mail them via DHL to Poland for repair/replacement. That will pretty much cost as much as buying a new one. So no thanks!


(Adam V) #2

Exactly what happened to me… it’s a bad Product


(Ron) #3

How many failed on you? I am out 2 to that’s $100 down the toilet!

The design of this thing is terrible. It’s hard to get an exact sequence of presses and they made the reset for the switch (press exactly 5 times, then press and hold). Is that press and hold on 5th or is that a 6th press? I interpret as the later but honestly it doesn’t seem to do anything anyway.


(Adam V) #4

I bought 1 when it first came out. I wrote that DTH and then it failed within a few days… got the same stupid message about sending… and just decided it was an expensive experiment


(Ron) #5

Mine worked just long enough to trick me into buying a second one. So double expensive experiment :slight_smile:


(Robin) #6

I had different issues with events not being sent on first press after a sleep… luckily mine failed quickly enough to send it back!


(Ron) #7

I took apart one of my buttons. Now making a connection manually and pressing the tiny red button on the board it works fine.

The problem is simply the design of the button itself. The electronics are still working. I am tying to figure out a better way to put it back together again but basically i think it simply doesn’t make good connections the way they built it.

The problem is the connections fatigue over time so they are not made correctly. Putting this back together I can make it work if I am really careful about placing the connection from the base against the connector on the board. However it works for about 4 clicks and then stops again. This needs a new design. They clearly never stress tested this thing!


(Ron) #8

Adding some photos of the flaw.

The issue is the base seen here

connects to the negative side of the battery and needs to make a circuit with the board in the top of the button.

That connection is made using this springy metal connection, seen here in a new button.

Which over time (about 3 months of use in my case) compresses to the point of losing contact when you press on the button causing the chips on the board to lose power and reboot.
You can see the compressed connector in this photo.

My recommendation remains to stay clear of this button.