Tuya wifi bulb

This is weird, had 2 Tuya app wifi bulbs running forever with no issues, both bulbs worked in the Tuya app and with created scene control in ST

Recently one bulb has decided to not switch on or off ? Works perfect in Tuya app but not in connected scene to ST

Deleted Tuya scene for on off, removed Tuya integration from ST, created new scene for on off, re connected ST Tuya integration, all devices found

But the bulb, although showing as offline in ST (normal behaviour) still refuses to switch on off if included in automation from vswitch ??

Everything else from Tuya works as it should with the scene integration and off line status but online in automation

Any thoughts ?? Is there an Edge driver where I can just bring the bulb onto ST direct ?? ST hub v2

Did you try using the ST web application to toggle the on and off scenes. After a new integration you need to do this to “wake” them up.

Never needed to do that before Paul and tbh didn’t know that was even needed at all ??

Non the less thanks for the tip, unfortunately all connected scenes seem to be online but still no joy from a vswitch in the app

And I just tapped the alleged online device in the Web app and it says offline now ??

Strange !!

Issue resolved
Didn’t want to do it but had no choice,
removed device from Tuya app
Deleted any smart scenes in Tuya app indicated as off line or not working
Re conected bulb to Tuya app
Re discovered in Echo
Removed Tuya integration with ST
Re conected ST Tuya app

All seems to be working as expected now but it was a ball ache