Tuya connection issues

Currently foxed on this one

Tuya connection through c2c on several devices, one device decided not to switch on or off, unable to resolve the issue I removed the integration from ST, re added the account by following the linking procedure and now although all the devices appear in ST all show cloud off line ??

Anyone else having issues or thoughts

Did you try powering down the affected device?
I had a Shelly 1 wifi switch that stopped working with both ST or Alexa. I deleted the device and re-added. I deleted the integration and re-added. Nothing worked. Than I turned the circuit breaker on and off and the device responded.

Any suggestion welcome Paul, thank you, unfortunately it had no affect, the connection to Echo seems to be fine, just the ST connection seems to be offline

Maybe they are switching their integrations to edge?

With so much going on Andreas, at this point anythings possible

1 Like

Nope, solved the issue, what has happened looks like a 2 fold issue

  1. User mis management
    I have a feeling I uninstalled by accident an automation connected to the affected device, not totaly sure but it appears that was what stopped the device responding as I use a virtual switch for on off

  2. Incorrect Tuya integration
    Tuya devices I now remember show as cloud offline by default when connected to ST, this gives the impression visualy of a faulty cloud connection … but.

If a virtual switch is used to connect the v switch ‘on’ to the tuya device ‘on’ and the v switch 'off 'to the tuya device ‘off’, the v switch operates the device perfectly fine, even though the Tuya integration shows offline

Currently using the new ‘automations’ tab to check old connections that are broken and fix them, which on a side note would have been a pig of job before the introduction of the tab