Turn on Fan based on outdoor/indoor conditions

I can do this today because I have an Ecobee, Smartthing and an IFTTT account. But the problem is that is not smart. For example, it executes the switch on every time the temp crosses the threshold. I want to turn it on only if there is someone present in the house or my mode is Home, not on Away mode. Or go even further, only at home and between 9am-6pm.

Is there a way to currently do this or do I need to have a new Smart App?

If this is the only thing that IFTTT will ever access you can go down in the addition settings and say only happen when home mode or whichever modes you want. Other than that you probably need a new SmartApp. Unless @yvesracine has something.

Hi @rey_rios, you’d be able to do this using this smartapp:

The only drawback is that you would then rely on ST scheduling only (not ecobee’s scheduling), which is starting
to be better (as ST is implementing a new scheduler), but it’s not as reliable as ecobee.

I tried to work around the ST scheduling issue as much as I could, and I think the smartapp is quite reliable now.

This smartapp has been designed for controlling the temp and fan settings based on rooms, zones, and schedules that you configure for your home. You can run the schedules only when one or some ST hello homes are set (can also be custom ones). An outdoor temp sensor can be used to trigger more heating/cooling or a specific fan mode, or even to switch the thermostat mode (heat, cool, auto).

The smartapp setup (i.e. rooms, zones, schedules) takes a little bit more time than a regular smartapp, but if you plan to add smart vents later, this smartapp can grow with your requirements.


1 Like

@rey_rios, after 2nd thoughts, I modified also ecobeeSetZoneWithSchedule to provide the same
control over fan settings.

This smartapp actually uses the ecobee’s scheduling to control the temp and fan settings within a zone.
It will override the fan settings set by ecobee’s climates when needed (example: the outdoor temp’s threshold has been reached, and you want to change the fan settings to ‘on’ instead of the ‘auto’ default).

These 2 smartapps are now in my main branch.

Let me know of any feedback.