SmartThings Community

Turn off lights after 10 minutes

This is truly a stupid name. I’m pretty sure the only reason they named it that was because the name of the shortcut app that you could install from Lights & Switches was called that. But, you never saw that name in Lights & Switches as an option. It was just “Turn off after some minutes”, or “Turn off after some time”. Then you’d set it up, and voila, you had an app called “Light Power Allowance”, or something like that. Even that was stupid. ST should just call this what everyone thinks about it as, and what it actually does. @tslagle13, Help us out here, and point out to whoever made this decision how it’s going to confuse everybody, makes no sense whatsoever, etc.

1 Like

I agree, unless they plan on using it for other purposes in the future, like true power allowance exceeding X Watts?! Tagging @slagle as @tslagle13 is Tim’s old name tag…

The old app that did the same exact thing was called power allowance. It was named so for parity.

Yes, it was named that AFTER it was installed. But when you went into Lights & Switches, the option was called “Turn off after some time”, or something very close to that. So the user never saw “Power Allowance” as a choice!

Anyone having issues with lights not turning back off? They are inconsistently sending an “off command” and often find lights on for hours until I manually turn them off. Mostly occurs with Aeon sensors, versus Fibraro, but the Aeon are outside, Fibraro are inside. I have read that if motion is detected during the “time out” period it causes issues. Thanks!!strong text

Does anyone know of any smartapp or 3rd party code for ST’s zigbee smart outlet which would start that power allowance timer when wattage was greater than 0 (light has been turned on) and would then turn off the smart outlet 20 minutes after the light was turned on, or would be reset if it was turned off manually before the time frame?

So is there a way to make this scenario work?

  1. Trigger when presence detected
  2. Turn on the lights
  3. Wait 10 minutes
  4. Turn off the lights

I only want to trigger this when the presence is detected. If I manually turn on the light I don’t want it to shut off after 10 minutes. Can that be done?

interested in doing this for my front porch light.
When presence detected, turn light on for 10 minutes, then turn off.

I’ve set up a CoRE piston to try my hand at that app. Wondering if its overkill or there is a simpler method. I have tried Stringify but didn’t have any success, which is a shame because it seems like it was easy to set it up (unless I did it wrong)

I have that setup with core

Found this Wiki and was able to get this working for my front porch lights. Took a few minutes to setup but works great.
http://thingsthataresmart.wiki/index.php?title=How_to_create_a_virtual_timer_for_a_light

1 Like

This is easily accomplished via CoRE

If:
presence changes to “PRESENT” (make sure you select any if you have more then one)
Then:
Using light
turn on
wait 10 minutes
turn off

I have this exact one…

Curious, is there an advantage to using webCoRE vs. the Smart Lighting app?

WebCore allows for much more complex rules, such as “if A and B, do C unless D.”

The official smart lighting feature only supports very simple rules. But it can run locally, which webcore cannot.

On the other hand, I believe webcore allows you to back up and restore rules that you’ve already built, while smartlighting does not.

So if you have a particular use case that can be accomplished with smartlighting, it’s up to you whether you choose to use that or to use webcore (since webcore can do everything that smartlighting can do except run locally).

Some people use smartlighting for the simpler stuff, some people only use webcore. It’s just a matter of personal preference.

1 Like

Forgive my newness, but when you say “run locally”, you mean it can run without an internet connection as long as the internal LAN is up?

For simple ‘rules’ like the above one, they can run locally. i.e. do not need to talk to the ST server to run, PROVIDING your device can run locally and so does your smartapp.
You can search here. (These url’s are for the EU shard. I’ve highlighted what will be different for the shard you could be on.
https://graph-eu01-euwest1.api.smartthings.com/localDevice/list
https://graph-eu01-euwest1.api.smartthings.com/localInstalledSmartApp/list

-eu01-euwest1

1 Like

It’s not the LAN, it only applies to zigbee or Z wave devices. For example, the SmartThings/hue bridge integration cannot “run locally” in this context, even though it is a LAN integration.

On this forum and in SmartThings support materials, “run locally” means " run without access to the SmartThings cloud account." But it’s only some devices, and only The official smartlighting feature and a little bit of Smart Home Monitor.

For example, routines cannot run locally. Nor can your phone communicate with the hub without the SmartThings cloud even if both are on the same Wi-Fi network. ( technically they could, but the SmartThings architecture does not allow it.)

1 Like

So, was there a way to do this with Smart Lighting? If so, and using “power allowance” what actually triggers that timer function, or is it in play every time the specified light comes on?

Thanks

If you just set it up in smart lights, then it will happen every single time you turn the light on. So it will always turn itself off after 10 minutes.

If instead, you want it set up so that you can sometimes have it sometimes turn off after 10 minutes but other times, such as when you just toggle the light in the mobile app, it stays on longer, there’s a how to article in the community – created wiki on creating a virtual timer that will let you do that. :sunglasses:

http://thingsthataresmart.wiki/index.php?title=How_to_create_a_virtual_timer_for_a_light

1 Like

Thanks JD, that’s pretty much what I had figured on.

TG

1 Like

Okay, so I set a power allowance trigger for my light to turn off after 5 minutes. Problem now, is I can’t turn the light back on, once I turn it on, it immediately goes back off. I’ve deleted the automation and this is still happening! Any ideas?