Trying to get the AEON Smart Energy Switch to publish data

I am using the AEON Smart Energy Switch. I can turn it on and off and I can usually get power and energy reading if I hit refresh, but it doesn’t automatically update. I am pretty sure that on at least one of them I specifically chose the SES (as opposed to generically hitting Add New Device)

Also, is there any way in code that I can disable the ability to turn it on/off ? Would that require creating a new device type ?

If I do create a new device type, how do I access it ? Would it automatically appear it in my SmartThings app ? I tried to add Foscam from a template and it did not. I don’t really see any documentation that tells you how to implement the device types… (access them from code and associate with hardware)

I just re-did it and I made sure that I chose AEON SES. It all works, but the power and energy only update (in SmartApps and SmartThings app) when I manually hit the refresh button.

I know it is possible to have the SES update automatically but I haven’t been able to create a device type to accomplish this.

As a stop-gap I use the pollster app for this:

I have them poll every two minutes.

@jmay33 and @jmay33, I have a couple of these reporting anytime the data changes. Try my device type and tap on the Configure tile:

The Configure tile should set things up right for reporting data. You can always go back to ST’s default device type.


Thanks, I wont be at work to try this until Tuesday. One of my devices is actually a washer too !

@johnconstantelo is it possible or do you know a way to automagically reset the values say once a month instead of having to manually hit the reset?

Hi @chaospup, off the top of my head I would think that maybe a SmartApp could be written based on a date to execute/call “reset()”. The one thing (of many) I’m terrible at is SmartApps. I haven’t spent a lot of time writing those yet.

Cant save this device handler. Get the following error:

Org.springframework.dao.DuplicateKeyException: a different object with the same identifier value was already associated with the session: [physicalgraph.device.CapabilityDeviceType#physicalgraph.device.CapabilityDeviceType : (unsaved)]; nested exception is org.hibernate.NonUniqueObjectException: a different object with the same identifier value was already associated with the session: [physicalgraph.device.CapabilityDeviceType#physicalgraph.device.CapabilityDeviceType : (unsaved)]

Hi @cdikland, that doesn’t look good. Make sure you don’t already have it saved, and/or close any browser sessions and try again (if it didn’t show up).

No luck… :frowning:

As far as I can see, no device like it in my list of Device Types. Been a while since I created a device type. Just to be sure I:

Selected Create New Device Type
Select From Code
Paste in your code
Press Create button (error occurs then)

Is that right?

@cdikland, yep that’s the process. I just did those steps and changed the following line to make sure I didn’t have a duplicate: (v3 to v4)

definition (name: "My Aeon Home Energy Monitor v4",

YAY!!!:smile: That worked.but dont know why … I would never have figured that out… Thank you very much…

Awesome! It’s ST, so who knows… :wink:

1 Like