Troubleshooting power switch that keeps changing state every couple of minutes

Have an integrated power switch (Ubisys S2 according to the hub) that recently started to switch state (on/off/on…) every few minutes. I guess it could be the switch itself malfunctioning, but could also be some automation/scene “loop” I guess.
Any suggestions on how to get to the root of this? Can see the events triggering in the log but not what caused the event is.

1 Like

You could delete the switch and then re-pair it. That would give you a clean slate eliminating any automations that might be causing any looping.

1 Like

It could be some random automation, but the most common cause for the symptom is the switch overheating, or recognizing a power surge, and it’s a safety shut off.

Because of the potential safety risk, even though it’s annoying, I would agree with the step of removing the switch and then re-adding it to remove the possibility of a random automation. Then, if it’s still happening, it’s time to consider an actual physical switch fault. :thinking:

It started happing for me too after a recent OTA update. I was told they’d provide a solution within 2 weeks.

Thanks yes, got the same answer from “provider”, apparently many affected and they are working with Samsung to solve it.
Unfortunately I deleted the switches which was overkill (it turned out) so still need to figure out how to get them back into the network. Question for another day!

I tried pressing and holding the button for 15 s, and the spontaneous flipping on/off stopped after that. It has not flipped for 20 minutes now, while it flipped every 2 to 4 minutes earlier.

Nice! Still good?

Still good, but I noticed that I can force the problem to appear again. My HomeButton and AwayButton are both on the same S2 switch. Turns out that after the driver update my HomeButton also has become the AwayButton. Clicking the HomeButton only gives me indication that the AwayButton was clicked, and this makes the problem with the flipping appear again.

I fixed it by once more holding the AwayButton for 15 s.

Really looking forward to a solution to this. Now my HomeButton is useless.

Heres how to fix it:

Delete the Home and Away Buttons from the app. This step is very important and it won’t work without it.

Find the fuse to the hallway where your Home and Away buttons operate. Turn the fuse off then on, about a second in each state, repeating the sequence a total of five times (ending in On).

Go to any room in the app and press the + in upper right corner to add device. Press the search icon to search for Ubisys and click it. Do not click any switch suggestions, just Ubisys.

It’ll ask you to scan a QR code, but click Add without QR.

Eventually it will find ubisys Switch and that it added it (this is the step that fails if you have not deleted the old buttons from the app). Press Done.

Go to your units in the app and try to find ubisys S2. Click it. Now observe the screen as you click your physical buttons to see which is Switch 1 and which is Switch 2. Remember it!

Now add the correct switch to the correct Home or Away routines as usual.

Yes that worked! (Eventually, had another button on the same fuse and took a few trials to get both back)