Troubleshooting Aeon Labs Home Energy Meter v1

Thanks, did it in the IDE works great. Would you please provide the Github settings so I can add it to the repository for future updates.

Hi @joelw135 and @Jimxenus, turns out v2.2.2 and v2.2.3 (Android) fixed the rendering issue, so I just updated my code in Github so it’s the same for both OS’s. Thanks!

I tried every combination for the settings page but couldn’t get it to take. I used:
“jsgs350” “my-aeon-home-energy-monitor-no-battery” “master” but didn’t work didn’t use quotes in the IDE.

Hi @joelw135, sorry I forgot to include the Github repo settings. Here you go:

Owner: constjs
Name: jcdevhandlers
Branch: master


Thanks that did it, and the line changes fixed the IOS text.

1 Like

How do I add the battery information to my unite as I have no power plug availabe and must use the battery. Also I cannot get mine to calculate watts to K/W its reporting watts no problem but Im not seeing a change in cost. its at —

To add the battery tile AND to set parameter 12 to 1, please use this device handler:

I saw your PM about kWh, and while you can tweak parameter 12 to enable it while on batteries you’ll quickly drain them as well.

After you get the DH all set up in the IDE, be sure to Save and then Publish for yourself and change your device to use it. After that, go to the mobile app, go to your HEM, make sure the preferences are the way you want them (tap on the gear in the upper right corner), and then tap Done. Once the HEM device comes back up, scroll down and tap on Configure.

It will take some time for configuration settings to take effect because you’re on batteries, and the HEM’s minimum wake up interval is 4 minutes.

Hey @johnconstantelo I’m not sure if this is the right place to post but I (think) I have three issues:

  1. What’s the vertical box on the left.
  2. The minimum value never seems to be populated and so is stuck on null.
  3. What is the ‘–’ box for?

I have the ‘no battery’ device type.

1 Like

Thanks, that did the trick!

1 Like

Hi @Benji,

That’s supposed to be icon that says “Activity”, but ongoing text/tile rendering issues/differences between Android and iOS causes that to happen.

Tap on “Reset Minimum” and that should do it. That will also fill in the box replacing “–” with a message about what was last reset.

1 Like

Perfect, that did the trick! Thank you!

1 Like


I’d like to use my HEM v1 to monitor two 110v devices (washer, gas dryer) at the same time.

For some reason I can’t find the discussion regarding how to do that - I believe I have to use a different device driver than yours.

Can you point me in the correct direction, please?

I think this is what you need?


^^^ The post right above this. Thanks @greg!


Withdrawn figured it out.

Just wanted to say thanks for this code! I had just installed the V1 version of this energy reader after getting a great deal ($11 bucks shipped), but was underimpressed with the reporting out of the box. Fortunately, Google brought me here, and after a few stumbles of installing the proper device handler, I got this working.

Thank you! I may explore adding code to the config to account for different kWh costs at different periods of the day, but this is a great start.

1 Like

Great Job. Bought this and thought for the longest time I had the latest (v2 or v5). Turns out it was V1 ($17 shipped from Buydig) and until Google brought me here, I was not happy at all with the device handlers. Very grateful for all the work!


Just as an update, it looks like the github repositories have moved here:


First, thanks to everyone who has contributed to this topic–and especially @johnconstantelo for developing and maintaining his HEM device handler.

I’m a noob to Smartthings and Aeon’s HEM. I have some coding and IT skills.

I recently purchases an Aeon HEM hardware V1 and Smarthings Hub V2 in order to start monitoring our household energy use.

I have read through this thread and tried to cull the important setup points; however, this still isn’t working for me. After successfully setting up my Smartthings Hub V2, here is what I’ve done so far:

  1. Installed the HEM V1 clamps onto the two leads going into the main circuit breaker in my breaker box. I believe I did this correctly.
  2. I am using the USB AC adapter to power my HEM V1. It wasn’t clear whether it is also useful/recommended to include batteries (I’ve left them out for now).
  3. I paired the HEM V1 Z-Wave to the Smartthings Hub through the following process (which I’ve done a number of times now):
    -Exclude (if already paired, light on HEM V1 solid red)
    -Reset both devices (I always reset the HEM V1 and sometimes I reset the Smartthings Hub)
    -Pair HEM V1 again with black button under battery cover and the Smartthings app
  4. I created a Device Handler in the Smartthings IDE using @johnconstantelo’s code, I saved and published it ‘for me’.
  5. I edited my HEM Device to use this new Device Handler.

After this didn’t work, I continued to scour this thread and found an update to the HEM V1 firmware (3.67) posted here. I downloaded this and used the USB cable that came with my HEM V1 to perform the update. I used the ‘two phase’ driver, assuming this is really referring to the number of leads on my HEM. That update didn’t seem to help and I ended up reverting to an earlier version (3.61) of that driver that I found here, I’ve also tried version 3.64 too.

If I view the event log, I can sometimes see that there are periodic ‘unhandled event SensorMutlilevelReport’ that at least makes me think that the HEM is trying to communicate.

I can also see that when I press the ‘configure button’ on the device handler UI, I get the following error:

I appreciate any thoughts and guidance on next steps here.

Here are some questions:
Am I missing a step or not doing a step correctly?
What is the best driver to be using for Aeon HEM hardware V1?

Any other tips/suggestions to help me get unstuck are greatly appreciated!

It doesn’t look like you’ve missed any steps, so what I’d ask you to try is to go into the device Preferences (tap on the gear icon) and reenter the default settings. Once you do that, tap on Done and it will cycle through the configuration process. Watch your live logging again to see if that error comes back.

There really isn’t a “best” DTH because it’s all up to how you like to see the device in the app. Some are simple, and some are like mine. The basis for all of them is usually ST’s original that’s been tweaked a lot over the last 2 to 3 years.

Try going through your preferences and let us know what happens.