Trouble with routine dimming lights properly

For some reason, this routine works except the dimming to 10%, it only changes on one of the two lights. The other light remains 100%. Color changes to blue every time, it’s just the dimming which is problematic. Any thoughts on how to improve this routine and get the results I’m trying to achieve? Thanks!

Are these devices on Edge drivers?

If so, I’d be curious to see the driver logging to see if it is sending the proper command to the 2nd switch. Need to figure out if it’s the Routine that is getting it wrong or if the switch isn’t responding correctly.

Do you always want Light 2 to match the on/off state and dim level of Light 1? If so, I’d consider association groups.

Brand and model of the lights? And if you are using an edge driver, which one?

1 Like

The lights are…

Driver being used is…

The switch is a vEdge, virtual switch using this driver…

Yes, I want both lights to turn on, change to matching color and dim level. I don’t know what association groups are or how they work. If that’s what I need to do, I’ll need to do some reading up on it.

Hi @162884

Try removing On command, clicking on the On action, so that it is deselected
Do routines only with set level 10% and set color.

set level and set color turn on the lights

1 Like

Association groups are a feature of Z-wave devices so are not applicable in this case.

Thanks @Mariano_Colmenarejo! I’ll give that a try later today and report back.

@Mariano_Colmenarejo, I just tested it and it worked perfectly! Thanks!