Trane tzemt400ab32maa thermostat wont connect on zwave

I am VERY new to all of this but I am looking for some help. I just came to the realization that my old nexia equipment is fully functional with ST and I am in the process of setting it all up (SO EXCITED!). Everything has linked up with no problems at all (Light switches, door locks, etc) except for my thermostat. I have the Trane tzemt400ab32maa and every time I try to add it to the zwave network nothing happens and doesn’t detect it at all. I have tried to exclude it multiple times and then try to include and still nothing happens. No reaction on ST app at all. I grabbed extension cords and the longest dang CAT5 cables I could find so that its about 7-10 feet away from the thermostat and still, nothing.

Any help would be greatly appreciated!
Thanks, Matt

Welcome to ST and the community!

These search results may help you:

Looks like you’ll need the device handler for this:

Since you’re new, I highly recommend reading up on how to use custom code:

Thanks for the warm welcome and such fast help!
I “force added” the device using the developer options and entered the code you had posted. I now have a device on my phone app but it still isn’t communicating at all with my thermostat. I feel like I may be missing something huge and obvious but for the life of me I can not figure it out. I am not a guy that understands coding at all so I apologize if these are dumb issues I’m having.

I go to the thermos and hit “yes” to add to the zwave network and nothing happens on either my phone or the thermostat. It is also giving me 000 when it lists the ZNID indicating it is definitely not connected to any form of a network. Also, for the record I dug out my old Schlage hub and it connects to it no problem. (Yes, I exclude it after I connect to it) :slight_smile:

Either way, is there anything else I could try that you know? Thank you so much for your help!

I realize this is an old thread but I am having the same issue with my Trane thermostat and do not do any coding. I did copying and paste the code that you recommended to create the app but I am getting this error:
startup failed: script_app_metadata_f848eee9_6e91_4e0f_83cd_6643f2b61e30: 619: unexpected token: private @ line 619, column 1. private getStandardDelay() { ^ 1 error

It is pretty much are the end of the script and I have tried making some changes but seem too make it worse.
Any help would be greatly appreciated.

Thank you!

Hi @jfdodson, lets double check a couple things. First, make sure you are creating a device handler and not an app, and second, make sure you have a fresh copy of the code with no changes.

1 Like

That was the problem. I was trying an app. I got it working. Thanks for the fast reply!