TP-Link Kasa Edge Driver (also LIFX)

No idea, but you have the official c2c integration for those devices.

How do I get the logs of my hub so I can check to see why I can’t find any devices.

You need to use the CLI.

Hey everyone,

The release channel has been updated with the following fixes that are currently in beta:

  • Fixed issue where device state wasn’t being displayed in the app right after discovery. This should remove the need to alter device state outside of ST to get things working correctly.
  • Fixed issue where brightness level wasn’t being updated for switches.

Multi-component device support has been added to the beta channel. This supports Kasa products like power strips, dual plugs and the in-wall outlet as multi-component devices. The following models should be supported:

  • HS300 (tested)
  • KP303
  • KP200
  • KP400
  • EP40
  • EP40A
  • HS107 (tested)

There may be other multi-component Kasa models that I’m not aware of. If you have one that is not working properly, let me know and I’ll try to get it resolved.

Here is a sample device card of the H300 with energy monitoring:

As always, thanks for using the driver!


@ZacM1979, @Sixoul: Shoot me a DM and I can try to help get your devices going. Getting some logs around the time of discovery will be the most helpful.

1 Like

I’ve tried resetting my hub and starting from scratch. Still unable to find my kasa devices. Does hardware version matter, firmware version?

It does. Do you have a smartthings wifi mesh hub? Those are tricky to get working. If you are using them in their typical setup, it won’t work here.

I’m using an aotec smart hub. I’m able to get the c2c to work but I can’t discover them to use the edge drivers.

OK. The only other thing I can think of is that you have 2 separate subnets in your house. Is the Aeotec hub connected to your same router as your Kasa devices? Do you have a separate router than modem? If so, is the hub connected to the modem and the Kasa devices to the wifi router? Do you have 2 separate wifi setups in your house? Some people do this for security reasons.

I have the kasa connected to a guest network that’s 2.4ghz and the hub into my modem. Could this be the issue? I’ll have to see but I think I enabled a setting to not allow guest to find other devices

Bingo, that is it.
Your ip address for your devices will look something like 192.168.X.YY and your hub needs to be on the same subnet number (the X) or it won’t work. Even if there was a setting, it might not make a difference. It needs to be on the same subnet.

They are and it was this setting. It blocks the guest network from seeing anything on the main and vice versa.

1 Like

You have 3 options:

  1. Move the devices to the same subnet as your hub
  2. Move your hub to the same subnet as your devices
  3. Do nothing and not have local control over these devices

I realize your question is a month old but have you tried creating a lighting group?
In the room with your lights, tap the + (add device) icon and ‘Create lighting group’ option is on that menu.

Sadly, Lighting Groups doesn’t support color either.

I’m hoping @BarryA, @whoismoses or one of the other folks that worked on Lifx devices can enable local color sync someday.

Or, ideally, ST realizes this is basic stuff and enables it.

Oh, I didn’t know this driver didn’t support color adjustments for lighting groups. That’s useful information because I was just about to install this driver for my LIFX devices.

It has nothing to do with the driver. There is NO driver, stock or otherwise, that supports that. Lighting Groups itself would need to support color sync, and it doesn’t. Neither does Smart lighting.

@Mariano_Colmenarejo recently released a driver for Zigbee bulbs that allows this, but it doesn’t work with the stock Lighting Groups either, he has his own implementation within the driver.

Presently, it is impossible to sync LIFX bulb colors within the ST environment. The fact that @Mariano_Colmenarejo was able to do it with his driver indicates it may be possible for the Lifx one.

I’ve asked @nayelyz about this a few times but it doesn’t seem to be a priority for the dev team at the moment.

I really don’t want to replace my Lifx bulbs with Zigbee or Hue but there may be no choice. Sadly, the color saturation is second to none on Lifx vs the other brands.

Yeah, I understood what you meant but incorrectly phrased what I wanted to say: I didn’t know the ST app doesn’t control color of lighting groups. I’m guessing you have already checked the Smart lighting app and it doesn’t have this function either?

@BarryA does the HS300 still require setup via the TpLink app? Can it be configured and setup entirely in ST?

I believe you need to add it to your WiFi network with the Kasa app. You do NOT need to link the Kasa and ST accounts.

1 Like