TP-Link Kasa Edge Driver (also LIFX)

Now I have 2 of every LIFX bulb and Switch after install.

Once you get the Edge Driver working you need to delete the official c2c integration. That should get rid of your doubles.

Thanks, removed LIFX linked services, (c2c I think). Now only 1 of each.
LIFX switches don’t work with this new driver. Maybe updates later on.

1 Like

Tagging @BarryA

1 Like

Hello everyone, any update on the Smartthings Wifi Mesh issue? I just enrolled on the beta channel, but non of my HS300 show up when scanning nearby (I have the wifi mesh hubs in router only setting and all hubs and HS300 are in the same subnet network)

I have an hs220 that keeps turning itself on after 10 mins or so. Is anyone else noticing similar? There are no routines firing at that time that could be triggering it. Could it be some kind of sync issue? Edit… Looks like this is happening with several tplink devices running locally with this edge driver. This is an always on media center but the history indicates it has been power cycling frequently.

What is the correct setup for the ST Wifi Mesh Hub to make this driver work?

1 Like

If you want to keep your current smartthings hub, without creating another smartthings hub…

  1. Disable Wifi from your current hub
  2. Reset all other mesh hubs
  3. Make one of the reset hubs your new primary wifi
  4. Make the others (not the smartthings one) secondary to that new primary wifi
  5. Connect your current smartthings hub to the internet on your current subnet

Note:

  1. You’ll be left with one less wifi hub to feed your mesh. Do NOT try to use the wifi (with the same SSID) on your current smartthings hub. It will mess up your connectivity.
  2. You may need to shuffle locations of your hubs around so that your new primary wifi hub is where your old smartthings/wifi hub was

OMG, so basically making one mesh hub behave as a stand alone ST hub (without the extra functionality of a V3).

I’m not sure that I want to disable one wifi mesh hub to gain the local control of this and others LAN edge drivers (Hue, Harmony). I just hope the smartthings team give this possibility to their wifi mesh hubs or at least give a migration function for us with older hubs to jump to an V3 and keep using smartthings.

1 Like

Yes and agreed.

First of all, thanks for the drivers.
The discovery part worked flawlessly for me and I was able to add all my Kasa Bulbs and Smart Plugs.

Then I tested local control. It works great too. So that’s all good.

Now the big issue. While local control works, there’s so much lag between the action (pressing the switch) and the result (light turning on off). Between 5-10 seconds. Sometimes it also doesn’t do any thing, because I guess there is time out.

To the point, going I am going with WiFi only now because it is near instant and works 100 % of the time.

More details:
I have TP Link Deco Mesh router. Turn out, if you have both TP Link Router (Deco) and the Kasa Bulb, they can be controlled locally by default. I tested it as well . Took out the ethernet cable but kept the wifi on.

Also evident by how Deco shows Bulbs (only Kasa)

See how it says “Wired” for a Bulb. I guess it is TP Link’s way of saying they can work without internet because clearly I did not put a Ethernet cable to my bulb.

While the local control works, it also has this insane lag and success rate of like 50% or so. Even though it is Zigbee (I guuss); the Wifi Way is still superior. This is only an issue with Kasa Local COntrol. My other Sonoff Zigbee Switch and Hue bulbs do not have this issue.

@sdbg this is happening to me as well with one of my kp115 plugs in Smartthings.
However, i setup up a routine in the Kasa app to turn on another light if that Kp115 turns off.
Smartthings reported the light turned on/off several times a day, sometimes more, but that Kasa routine never fired.
So smartthings is lying about the plug power cycling.

I experienced the same thing in that is duplicated the switches …. I had a different experience though in that the new driver based devices cannot turn the lights on or off from the app. The driver sees changes made to the lights but fails to make any changes. I didn’t try them through a routine yet.

Interesting. I’d say there is an issue here for sure then. I updated the drivers on several devices to the BETA version and also reset the device itself and added back through TP link app. This seems to have corrected the issue for local devices now. Neither are randomly turning on and off or reporting that they are, even if they actually wern’t in some cases. I assume updating to beta drivers is what fixed it…

Just tested on the EP40 and works perfect!
I have some suggestions:
I don’t think is necessary to show the main plug (the one controlling the 2 outlets), even in the casa App is not showed nor the C2C integration.
It should be great if we can name each individual plug or even better if we can get them work as individual plug each, (at least for the plugs, maybe switches will be different, but plugs we usually use them to control separate kind of things)

1 Like

This is great! Tested and works. Now the question is…how to control individual outlets in routines?

I’ve been having an issue with one of the switches randomly turning on and off and the plugs turning on randomly. Any idea what the cause is?

Same… However, for me the plug is not actually turning on and off but rather smarthings is just reporting it.

I think false reports are better than it physically changing for no reason.

Yes but equally bad if you have routines that trigger based on on off status, falsely triggering