TP Link Kasa Devices with new official integration (July 2019): reviews needed

It also doesn’t update for me either. It only checks every 12 hours.

Strange, it was included in the press release.

Thanks to SmartThings support for helping me identify the issue. I ultimately had to unlink and relink Kasa in SmartThings to get it to work. I made the initial link to Kasa in September. All of the devices I have added to Kasa recently were working fine. The problem only seemed to occur on devices that were added to SmartThings before the updated integration went into effect.

A word of caution to those who are going to do this: it required me to redo every single room, scene, automation, and smart app in SmartThings and every room and routine in Google home. I’m probably going to have to fix some stuff in ifttt as well.

Also, when you unlink Kasa, make sure all of your stuff is deleted from SmartThings before you relink. I have roughly 50 Kasa devices and only about 10 of them deleted themselves. The rest, I think, were not automatically deleted because they were included in scenes. I also couldn’t delete an item at all if it was included in a Smart Lighting automation. The whole process has taken me roughly 5 hours so far and I still have to fix Google home routines and ifttt and other external services that link to SmartThings.

Good luck!

Edit: Also, I would recommend deleting scenes before unlinking if the only devices in the scene are Kasa devices. I had a scene get automatically deleted from smartthings during the unlink and it’s still showing up in Google Home and other external integrations and I can’t figure out how to delete it.


I am using HS100 with the lastest HS100 firmware, if i trigger the switch via Alexa i do not see the status change in ST (new app) . It would be great to get this working

Does it also have a physical button? Does that button cause SmartThings to be updated immediately?

Mine works - but I think it is different model. Are you sure you have latest Kasa firmware on the outlet?

1 Like

When did you add this to SmartThings? It has been my experience that if you added it before they implemented the callback procedure the only way to get it working is to unlink and re-link your Kasa account.



I added the kasa hs103 plug in the new SmartThings app. How do I get the device to appear in my SmartThings classic app? All my other devices are in the classic app as well as my routines and automation. I’d hate to have to migrate everything to get at a kasa plug.



Hi, I got it working, it turned out it was my setup. I had the HS100’s in an Alexa Scene , but the HS100’s were listed twice as a socket and a switch. So i had a little housekeeping in the config, and now it all works , even via the Alexa Scene of the two grouped HS100’s. I removed the HS100’s from the Alexa Scene and created a Tp-Link Kasa scene in the app, and then called that in an Alexa Scene with a 3rd light (not HS100)
I had a long live-chat with Kasa support today about the firmware versions. I have 3 different version of the same model of the HS100 and each version has a different firmware version, but all the versions are the latest. I have a version 1.0 and 1.4 . All working. Thanks guys @tgauchat @gregrun
ps. This is the newer ST App , I don’t use ST Classic App


Thanks Gregory, I didn’t have to re-add them, the older HS100’s were configured in 2018 and running perfectly ever since , all good.

1 Like

I’ve linked my Kasa account to ST V3. I can only see Kasa devices that I’ve had for a few months. I added 2 HS100 plugs a few days ago but they aren’t showing up in the ST app. Any suggestions? I’ve tried deleting the connection and re-adding it.

1 Like

obvious, so probably already done:
a. Assure the devices are installed through the Kasa App and can be seen and controlled via Kass
b. In the settings for the device, assure that Local Control only is NOT active.


1 Like

Thanks for suggestions.

Yes I can see and control the plugs in the Kasa app.

I can’t see any option for local control in the app. Can you explain how I can do this? I’m on Android if that makes any difference and the app is up to date.

The only difference I can see in the settings between the devices is the hardware and firmware (which are all up to date).

The ones I can see in Smartthings are:

  1. hardware 2.1, firmware 1.5.8
  2. hardware 1.0, firmware 1.2.5

The ones I can’t see are all hardware 4.1, firmware 1.0.0.

local control is in the settings for each individual device. You will see it only if the device is in local control (allows you to turn on “Remote Control” at the very top on the device’s settings page.

I can’t see anything about remote control or local control in the settings. Am I looking in the wrong place? Screenshot attached.
Thanks for your help!

Local Control only shows up if it’s in that mode. This usually only happens when there is a problem connecting to the cloud.

Go to the Kasa App and update your firmware. This was required for older devices to work with the new smart things integration.

1 Like

Ironically it’s the older devices that are working and the new ones that aren’t. Anyway, all devices have already got updated firmware.

I’m having the exact same issue. I have 4 TP-Link sockets in Kasa. 2 are old and 2 were bought and added about a month ago. The 2 old sockets show up in Smartthings using the Kasa integration, but the two newer ones don’t. They’re all correctly setup in Kasa and all cloud accessible.

The older sockets are model number HS100, hardware version 2.1, firmware version 1.5.8. The newer sockets which don’t show in Smartthings are model number HS100, hardware version 4.1, firmware version 1.0.0.

The Kasa app reports that all sockets are using the latest firmware/no updates available.

I’m in the UK, if that makes any difference!

Really hope someone can help.

It is time to talk to TP-Link and SmartThings Technical Support. The integration may have a problem. Both Gavacac and beavis should do this.

1 Like

Thanks for the suggestion. I’ve emailed Smartthings UK support, I’ll let you know what they come back with.

1 Like