TP-Link/Kasa Bulbs and Plugs Control

dth_wallswitch
dth_smartbulb
dth_lighting
dth_pocketsocket
dth_outlet

(Wasim Ahmad) #690

Wen i trying to save it giving me page saving error


(Wasim Ahmad) #691


(Wasim Ahmad) #692

Any help please


(Mark Goldstein) #693

‎1‎:‎58‎:‎29‎ ‎PM: info TP-Link Connect did not have any set errors.

392da5d8-643e-4080-b387-e51b25130560 ‎1‎:‎58‎:‎29‎ ‎PM: info TP-Link Connect did not have any set errors.

392da5d8-643e-4080-b387-e51b25130560 ‎1‎:‎55‎:‎45‎ ‎PM: error physicalgraph.app.exception.UnknownDeviceTypeException: Device type ‘(Cloud) TP-Link Plug-Switch’ in namespace ‘davegut’ not found. @line 180 (doCall)

392da5d8-643e-4080-b387-e51b25130560 ‎1‎:‎55‎:‎43‎ ‎PM: error physicalgraph.app.exception.UnknownDeviceTypeException: Device type ‘(Cloud) TP-Link Plug-Switch’ in namespace ‘davegut’ not found. @line 180 (doCall)

392da5d8-643e-4080-b387-e51b25130560 ‎1‎:‎55‎:‎40‎ ‎PM: error physicalgraph.app.exception.UnknownDeviceTypeException: Device type ‘(Cloud) TP-Link Plug-Switch’ in namespace ‘davegut’ not found. @line 180 (doCall)

392da5d8-643e-4080-b387-e51b25130560 ‎1‎:‎55‎:‎35‎ ‎PM: info Device Kitchen added to devices array

392da5d8-643e-4080-b387-e51b25130560 ‎1‎:‎55‎:‎35‎ ‎PM: info Device Fireplace added to devices array

392da5d8-643e-4080-b387-e51b25130560 ‎1‎:‎55‎:‎35‎ ‎PM: info Device Front added to devices array

392da5d8-643e-4080-b387-e51b25130560 ‎1‎:‎55‎:‎35‎ ‎PM: info Device Dog added to devices array

392da5d8-643e-4080-b387-e51b25130560 ‎1‎:‎55‎:‎28‎ ‎PM: info TpLinkToken updated to 3e30ef2d-A1f9WuhRMr6FtkhJTSF1vjB

392da5d8-643e-4080-b387-e51b25130560 ‎1‎:‎55‎:‎17‎ ‎PM: error physicalgraph.app.exception.UnknownDeviceTypeException: Device type ‘(Cloud) TP-Link Plug-Switch’ in namespace ‘davegut’ not found. @line 180 (doCall)

392da5d8-643e-4080-b387-e51b25130560 ‎1‎:‎55‎:‎06‎ ‎PM: error physicalgraph.app.exception.UnknownDeviceTypeException: Device type ‘(Cloud) TP-Link Plug-Switch’ in namespace ‘davegut’ not found. @line 180 (doCall)


(Mark Goldstein) #694

Here is my unexpected error


(Dave Gutheinz) #695

Sorry for the problem. I am seeing that you are using incompatible device handler and service manager. They are from different directories on GitHub. Go there and load the correct service manager and try again.

The problem is not all you. We are preparing to release a new version of the entire set - but this is in a different directory. Also, the GitHub integration may be out-of-sync.

Dave


(Mark Goldstein) #696

I went here:

copied both the SM and DH and same outcome.


(Dave Gutheinz) #697

Not knowing your level of expertise:

a. Did you select your location (hub) before copying, saving, and publishing the Service Manager and Device Handlers (if not, you would get error).

b. You do have a hub? (I ask, because this has occurred previously).

(PS - I will uninstall everything tomorrow and start from scratch. See if I get expected results or yours. There is always the possibility of some error in code not caught in testing.


(Wasim Ahmad) #698

Thank you very much.dave I appreciate for your help I fix things with new app with new device Handler awesome job I love new service manager you really done nice and awesome job I have a more than 45 device just a TP Link I love you man


(Dave Gutheinz) #699

Wasim,

Thanks for the kind comments. I originally did this for myself. Little did I know that it would let me interact with so many good people.

Dave


(Mark Goldstein) #700

This is my first time doing this type of programming. I do have a smartthings hub and have a z wave lock and smartthings outlet mapped to it. I checked and smartapps and no location shows. Can I update it or need to start over? Where do I update the location? I did not see a location field when I went to the my device handlers. Thank you so much for what you are doing for us!


(Mark Goldstein) #701

One other thought, I did not copy all of the information for the device handler as the top 38 lines asit seemed to be mainly descriptions. Could that be another reason?


(Dave Gutheinz) #702

Mark,

From your logs:
“392da5d8-643e-4080-b387-e51b25130560 ‎1‎:‎55‎:‎40‎ ‎PM: error physicalgraph.app.exception.UnknownDeviceTypeException: Device type ‘(Cloud) TP-Link Plug-Switch’ in namespace ‘davegut’ not found. @line 180 (doCall)”

The error you are getting is indicative of the smart app not seeing the device handler. Then namespace and name appear correct in your device handler paste.
Go over the installation to assure you did not make a mistake.
Install instructions:
a. log into the IDE
b. Select the “MyLocations” page (upper left).
c. Select your hub name. (must do this - major source of problems)
d. Select “My Device Handers”. If you have no devices - that is the problem. You will need to reinstall. If you do, continue checklist below:

To install device handlers:

  1. Select “+Create New Device Handler”
  2. On next page, select from Code. COPY THE ENTIRE HANDLER TEXT.
    3… Select “Save”
  3. Select “Publish”. MUST DO. Error source.
  4. Go back to “My Device Handlers”. You should see your device with:
    Namespace/Name = “davegut : (Cloud) TP-Link Plug-Switch”
    Status = “Published”

Good luck


#703

Dave, I’m using the old service manager and device handler. If I wanted to transition to the new one that is under TP-Link-SmartThings repo. Do I have to remove my devices and restart from scratch?


(Mark Goldstein) #704

Which app should I be using? I have classic and non-classic? I see virtual hub and virtual plug now listed. I have four TP link plugs and only shows one. I tried to add the four in the classic app and received the error again. I made sure that the location was filled when I redid the both smartapp and device handlers. I have two devices listed on the IDE site and not any virtual


(Mark Goldstein) #705

After I added the top 38 lines and published, it changed from null to cloud and I was able to add all four plugs and they work!!! Thank you.


(Steven) #706

Hi Dave. Thanks for this. Really helped me add my plugs to my house for AT. Just one thing I thought of today. I have I think about 5 plugs for Xmas that will be coming down soo all TP plugs. So how do I go about adding them so they are picked up on SmartThings. Do I need to re do the whole process again or is there something simple I need to do. Looking forward to your help mate


(Dave Gutheinz) #707

After installing the devices through the Kasa App and assuring they are in Remote Control, simply run the Service Manager (Smart App) and select Install Devices. It will detect any uninstalled devices and you will be able to select and install.


(Mark C) #708

Ive just noticed the the github intrgration is showing the smart app and not in the repository. im using
[davegut /Cloud-Based_TP-Link-to-SmartThings-Integration (master)] for the davegut : TP-Link Cloud Connect Smart App

and

davegut /Cloud-Based_TP-Link-to-SmartThings-Integration (master) for the davegut : (Cloud) TP-Link Plug-Switch Device handler
which is showing as linked

Can you advise of which are the correct files/combonations?


(Dave Gutheinz) #709

explicitly on the GitHub link:

Current Service Manager: smartapps/davegut/TPLink Cloud Connect V2.groovy

Current Device Handlers: any beginning with “(Cloud)”.

The current valid repository is:

All others are not current. The “TP-Link SmartThings” is in BETA. It works, but has some minor issues I need to resolve before going final.

These files will remain on GitHub but not maintained after 1 Jan (they have had no problems). They do work with the new SmartThings phone app.

Sometime in the near future, I will load the new version. Better smart app, merged device handlers by device type (no more separate hub / cloud DTHs). Smart app support for updating preferences on devices (not available on the devices for the new phone app, so added to smart app. They will have new names to identify compatibility.