TP-Link/Kasa Bulbs and Plugs Control

dth_wallswitch
dth_smartbulb
dth_lighting
dth_pocketsocket
dth_outlet

(AaronW) #508

I see the issue now. You forked the SmartThingsPublic from ST. You may want to rename your repository SmartThingsPublic to TPLink and then delete all non TPLink from the sub folders.


(Dave Gutheinz) #509

I will reread the instructions and rework the entire archive.


(Dhiman Das) #510

Hello Dave,
Thanks so much for putting this together.
Best


(bravo261) #511

Immense thanks to Dave for sure. he helped me out here last August and i left town before expressing gratitude.
Huge asset to the Tp-link users here!


(Dhiman Das) #512

Any suggestion on how to group connected plugs together, so that i can use google home to, say, turn upstairs lights on/off


(Dhiman Das) #513

Sorry i figured out that it can be done by trendsetter from the community. now having problem calling it from google home.


(John) #514

Thanks Dave,I have this working, it’s great. One question, if I turn a tplink plugin off via Alexa outside the smartthings app it seems smartthings does not see the change, is that as expected. Thanks and sorry if this has been asked.


(Dave Gutheinz) #515

Also consider SmartThings Routines. I have three examples:

Watch TV (turns on entertainment center, speaker, and two lights very dim in Den.

Read (Turns everything off except AC and light(s) beside bed) and some other item I want.

Sleep (You get the idea).

Wake - turns on certain lights, sets thermostat for the day, etc.

These can be activated by time or by a command and they work with Alexa. Google Play???


(Dave Gutheinz) #516

It will update at the refresh time. A better solution:

Enable the SmartThings skill in Alexa, add the TP-Link devices, disable the Kasa skill. Updates will be instantaneous. When done this way, Alexa provides all control of plugs and most for bulbs (level, color Temperature (120, 130), and color (130).

Dave


(Dhiman Das) #517

Thanks for being so helpful. Actually I was having an Android version
problem. Everything working fine with your codes and the trendsetter and a
new Android phone.
dhiman


(John) #518

Hi Dave, you are right, that worked, I did the same for my lifx skill also and now all is working instantly. I also deleted the older devices that were created by the TPLINK and LIFX skills that i disabled. Now all working , thank you Dave and for the fast reply.


(John) #519

Hi Dave, is there a step I need to do to see my TPLINK devices in Webcore. Thank You


(Dave Gutheinz) #520

Simple Answer: Nothing within the TP-Link device handlers or service manager. I do not use WebCore (installing today); however, you probably have to do something to connect to devices in each “piston”.

Verbose mode: I do know that WebCore works (from others in this forum). WebCore (and other apps, etc., typically use the published capabilities to detect devices. Below are a list of the capabilities that I have implemented. This integration is compliant with the commands and attributes for these capabilities.

TP Link Device Capabilities

Plugs/Switches
	capability "Switch"
	capability "refresh"
	capability "polling"
	capability "Sensor"
	capability "Actuator"

Bulbs
       ALL
		capability "Switch"
		capability "Switch Level"
		capability "refresh"
		capability "polling"
		capability "Sensor"
		capability "Actuator"
      Tunable White and Color
		capability "Color Temperature"
      Color
		capability "Color Control"

Energy Monitor Functions, add
	capability "Power Meter"
	capability "Energy Meter"

Custom Commands:
Bulbs:
command "setModeNormal"
command "setModeCircadian"
Energy Monitor Functions:
command “getPower” - Updates current power consumptions in Watt s
command “getEnergyStats” - Updates the weekly and monthly Energy Statistics

Custom Attributes:

    Bulbs
  	attribute "bulbMode", "string" - either Circadian or Normal.

  Energy Monitor Functions (in KWatt-Hours)
  attribute "monthTotalE", "string"
  attribute "monthAvgE", "string"
  attribute "weekTotalE", "string"
  attribute "weekAvgE", "string"

Dave


(John) #521

Thanks Dave, I actually found the answer in one of your past replies. I have them now visible, by adding them to webcore and refreshing. Thank you


(Shaun) #522

I’m having a problem. I cannot get TP Link to show up in the “My Apps” list. The list is just blank. I have reinstalled many times and even tried resetting the hub and reinstalling the app to no avail. I had the old version working fine, but I wanted to update to get the energy monitoring working. Once I updated though, all my devices had “Comms Error”. So I removed everything related to the TP Link ST integration and tried reinstalling from scratch but it still will not show up in the list. I tried reinstalling the old version again but it won’t show up in my apps still. Thanks Guys

EDIT -
OKAY WHAT THE FFFF
I decided to set up an account on my mrs phone for Samsung smart things. I invited her to my location. Accepted invite all well and good. I clicked on my locations and set it to home which is the same as my location. No smart apps or device handlers were there, even though the are the EXACT same shard. Whatever, I installed the SAME device handlers and smart app on her account on my location, went to smart apps, my apps on her phone and HEY PRESTO, TP link shows up. But I go back to my phone, the exact same phone/IOS, and My Apps is still blank. I’ve already reinstalled the app, rebooted and reset the hub. Still won’t work. Anyone have any idea why this would be happening? I can’t set it up on my mrs account as the hub is linked to mine so hers just says null. Suggestions?


(Shaun) #523

All good guys, I finally figured out my problem. It turns out I have 2 smart things accounts and the only difference between them is one starts with a capital. My iPhone auto corrects my email to start with a capital when i put it in the app, the auto-fill on my computer puts my email with a lowercase letter. I found it out by making a dummy location on the phone account and discovering the location wasn’t there when logging in on the computer. Sorry guys. Too bad you can’t delete smart things accounts, I’ll have to remember this for next time.


(Sean) #524

Hi Dave, this is a great tool. I’ve been using this to control four outlets (HS105) and four switches (HS200) with no issues.

I finally receive two color bulbs (LB230) from back order and have them setup in the Kasa app. I published the device handler for the bulbs (davegut : (Cloud) TP-Link Color Bulb Emon). However, when I save, I am getting the “Error saving page” red banner alert. I checked your documentation and can’t seem to find a solution to the issue and am therefore reaching out.

Let me know if there is some way I can help diagnose the issue. I have limited skills in the api. Thanks!


(Dave Gutheinz) #525

You must first install the standard bulb (no Emon) and then upgrade to Emon following the instructions on the site.

Download, save, and publish “(Cloud) TP-Link Color Bulb.groovy” and install, THEN update to Energy Monitor. (note that although it works great, the Energy Monitor function for the bulb is kind of useless. If you run the bulb 10 hours per day at full brightness, it will consume around 3KWH in a month (for me that is < 40 cents US.))


(Sean) #526

Thanks for trying to help me out. I published the correct handler. I am still getting the error. Here are the device handlers I have published:


(Dave Gutheinz) #527

Let me further investigate.