TP-LINK HS110 Smart Plug w/ Energy Monitoring, Wi-Fi Enabled


#87

Finally figured it out, Windows firewall was blocking the connection. I did two things to fix this:

  1. Switched my home network to a “private” one (go to wifi settings for the home wifi and set it to discoverable)
  2. Set windows firewall “Private profile” to allow inbound connections (go to firewall > advanced settings > windows firewall properties > private profile > set inbound connections to allow)

I hope this helps someone else stuck on this step! Thanks aapocketz for all the help


(Fernando) #88

I’m on the same boat. I would like to use the energy consumption to figure out if my TV is on in a CoRE rule.

If no one is adding this to the tp-link grovy script, I’ll try to add it myself. Just need to figure out if the kwh readings will be understood by the HUB device entry…


#89

hey aapocketz, another question for you. Do you have a version complied for the raspberry pi? I’m new to all this, after getting this working on my windows machine, I bought a raspberry pi W so I don’t need to leave my machine running all day. However, I get an error when I try to run the package on my pi: “exec user process caused exec format error” which online forums indicate I’m trying to run a docker image complied for Windows on the Pi (which is an ARM architecture).
Would it be asking too much to ask you to release a version compiled for the PI?


#90

Yeah if I have some time later I should be able to help.

The issue isn’t compiled code really, I think it’s an issue running the x86 Ubuntu phusion baseimage on arm.


#92

So I would just install the node.js script and run it directly on a raspberry pi without docker. I did update the docker image in a branch but docker seems sort of beta on ARM arch right now, and it doesn’t build in docker cloud.


#93

Thanks aapocketz, I got it running in node without docker like you said, working fine. Thanks again for all the assistance!


(@rnel) #94

Is there a way to make the port static also? It is changing incrementally once it restarted from the QNAP-Container.


(AlexB) #95

I’m not sure if you gave up on this but I saw this error while setting mine up.

My issue was that my HS100 was on a guest wifi network and did not have access to my lan ports where my raspberry pi was running the code.

I changed the wifi network to a non-guest network and everything worked.

I suggest you try pinging 192.168.200.28 from your machine with the nodejs code


(Dave Gutheinz) #96

HS110 energy monitoring support is added in the apps in the thread “TP-Link Bulbs and Plug Control”. I am the author. Feel free to use this as a guide.

Note that my approach is different from the basic HS100 app. I do most processing in SmartThings and have a minimal footprint on the server/bridge. I do not use the HS100 API in this approach.


(James) #97

Hey Dave G. I don’t mean to hijack this thread but I’m having trouble with 1 step from your instructions @ GitHub.

Scenario:
Try to get HS-200 working with Smartthings hub v2

Step I’m having trouble with:
Running the “TP-LinkServer_v3.js”

Background:
I’m using Windows as my Server PC
From the Node.js command prompt version is v8.1.2 (I downloaded the MSI as per your instructions)
I was hoping to get the results in your instructions when I ran the test but instead I get "SyntaxError: Unexpected token <"
I was able to run another test with a “Hello World” js and it worked
I also tried your “GetdeviceIPs.js” and same error

I might be totally doing this wrong but please point me to the right path. Let me know if you need to full Syntaxerror msg and any other info.

Thanks in advance for your time.

James,


(Mantas) #98

hello im just starter in smartthings. I need know or you crate Cloud-Based_TP-Link-to-SmartThings-Integration. because I do your metod but nothing happens. if is you crate this metod I need ask mi and I haw several questions .


(Dave Gutheinz) #99

Yes. Go to the below link and I will help.

In the meantime, assure that you have followed the published instructions explicitly. These are at the getHub site in a document “Cloud TP-Link to SmartThing Installation.pdf”. You might want to print these and mark the steps so you can be explicit on when / where the installation fails.


(Mantas) #100

I don’t find haw to write to you in email. becuose write here. what mi
problem.


what this red meens?


(Dave Gutheinz) #101

There is no error at the called line. However, there is something spurious on line 32 (indicated by the space between the two lines.

Usually done by not copying/pasting as text. I tested the app exactly as copied from GitHub this AM and it worked fine. Again, a copy / paste problem.


(Isriam) #102

i just used the cloud version of this and worked great.


(Mantas) #103

to my now to works great. problem was a numbers by the code lines. everything delet and works program.


(Cyndi H) #104

I’m not into coding and I’m new to HA and I’m just trying to figure out if you can integrate these with the smartthings hub (no coding involved) Thanks


(Tyler Durden) #105

You don’t have to code anything, but you have to install custom code that’s already been developed. It’s not too difficult to do. (First time is the hardest.)

Here is a link to a thread that discusses the custom code that will integrate TPLink devices to SmartThings via the cloud.

This is a link that explains how to install custom code in general.


(Cyndi H) #106

Thank you :slight_smile:


#107

not sure if it has been already mentioned earlier but integrating them via IFTTT is quick, simple and requires no code at all. in ST just create a simulated switch, authorize that in IFTTT, authorize kasa to IFTTT and then create recipes to turn on and off.

i can look up for instructions and paste here if anyone is interested.