Time based routines triggering 1 hour early

I have some routines that do things like turn lights on at specific times every day. They have run reliably for over a year. All time based routines are now triggering 1 hour early. Routines with period of time or sunset/sunrise still work correctly. I am in Arizona and we do not use daylight savings time. In the IDE my location is set correctly. This has been happening for 2-3 weeks now.
I have tried the following…
Disabled time based routines and then re-enabled.
Rebooted hub.
Deleted and recreated routines
Any idea how to fix this?

Edit: using V3 hub in USA

Just wait until clock moves forward this weekend. Problem might be solved by itself

any member of your household travel out of your time zone in the past 2 to 3 weeks?

Yes. I did and was gone for a few months. I often travel and it has never affected the time based routines before.

Theres your answer, for some strange reason ST takes rhe timezone from the device you loged in. So if your used your phone to do something on the app or platform it will use this timezone.