Three axis sensors stopped working in Smartthings apps (February 20, 2018)


(Scott Grabauskas) #1

As a beginner to coRE, I set up 6 pistons to monitor the state of a 3axis sensor (multipurpose sensor) to be used as a ‘mood cube’. Although I really didn’t think about it enough, I got it to work by a simple IF ‘sensor’ IS ‘right side up’ THEN ‘turn all the first floor lights off’, for example.

Last night the cube stopped responding. I tried changing the battery, but it wasn’t the cause. I panicked and uninstalled and reinstalled coRE. Now when I try to use any 3axis sensor as a trigger, I get an error when I try to save the piston “an unexpected error has occured”. I also notice that no matter what the orientation is of the sensor, I cannot get coRE to recognize it in the mobile app.

When I check the Live Logging, I get this error every time I try to save a piston using a 3 axis sensor as my IF trigger:

8:49:55 AM: error groovy.json.JsonException: A JSON payload should start with an openning curly brace ‘{’ or an openning square bracket ‘[’.
Instead, ‘-998’ was found on line: 1, column: 1 @line 3203 (subscribeToDevices)

I honestly can’t think of what could have changed between the time these pistons worked and stopped working. There was no firmware update, no software update, etc. I can get coRE to save other pistons using other triggers, or even the ‘OPEN’ or ‘CLOSED’ responses from the ‘Contact Sensor’ function of the multipurpose sensor.

ALSO, I tried to initiate the Samsung smartapp MOODCUBE found in the ‘Lights and switches’ category. When I choose a sensor and try to save to the second screen, the app hangs and will not allow me to configure the settings. It just shows a blank page. I get this error in Live Logging:

8:58:36 AM: error groovy.json.JsonException: A JSON payload should start with an openning curly brace ‘{’ or an openning square bracket ‘[’.
Instead, ‘-998’ was found on line: 1, column: 1 @line 295 (getOrientation)

Clearly I am having trouble getting information out of the 3 axis sensors. In the device listing the positions are registering when I move the sensors, however.

I apologize if this is a trivial issue or if I’ve not given enough information. I’m not a programmer and I’ve just begun using coRE. I am totally overwhelmed by the seemingly limitless functionality of this app.


(Greg) #2

something changed. my 3 axis stuff broke too


(Scott Grabauskas) #3

Again, I apologize for being obtuse, but how is this possible?


(Greg) #4

stuff in ST breaks sometimes. file a support ticket.

My suggestion is don’t mention CoRE in your ticket, mention the stock mood cube app. first line support will give you canned answer about not supporting custom smart apps.


#5

Anything that runs in the SmartThings cloud (which includes all custom code, including core and webcore) can break if they make changes to the cloud – – and they make a lot of changes to the cloud. :scream: They rarely announce the changes either before or after unless something breaks or adds new functionality.

The most important thing, as @greg mentioned, is to report it to support using an example from a stock SmartApp. Those will then get kicked over to engineering eventually, who hopefully will fix the problem.


(Scott Grabauskas) #6

Guys, Thanks for the info. I think I’ll spend more time on the boards since there are patient people like you who are willing to help out guys like me to understand. I’ve opened a ticket and I’ll follow up here when I hear back.


#7

My cube also stopped working. Please report back if you have news, thanks!


#8

Make sure you open a support ticket. The more people who report a problem, the higher priority the fix will get.


#9

I am getting the same message in webcore in the last couple of days

JSON payload should start with an openning curly brace ‘{’ or an openning square bracket ‘’

It is from the 3axis aswell.


(Greg) #10


(Ant) #11

+1 for broken mood cube. Will raise a ticket tomorrow. Seems when you go to edit the mood cube rules and click next it cannot load the config page. If you try to hit save it errors. Something has most definitely changed or broken in the smart app :-/


(Rick) #12

First post! My mood cube is down as well. I did the same thing others did and had the same results. I will report the issue as well - what is the best way to do that?


(Bill) #13

The Home Remote SmartApp is also affected by this issue.


(Scott Grabauskas) #14

So far, this is the response:

Steve (SmartThings)

Feb 21, 3:53 PM MST

Hey there,

Thanks for reaching out to SmartThings support. Sorry that you’re having
trouble with your mood cube, I’m here to help.

I’ve gone ahead and recreated the issue on my end and can confirm that
there is something wrong with the SmartApp, I will go ahead and escalate
this issue. Sorry for the inconvenience and someone will be reaching out to
you once the issue has been resolved.

In the meantime, please go ahead and try to reset your Multipurpose Sensor
by following the links here:
Samsung SmartThings Multipurpose Sensor
https://support.smartthings.com/hc/en-us/articles/213496343-Samsung-SmartThings-Multipurpose-Sensor
Samsung SmartThings Multipurpose Sensor (2015 model)
https://support.smartthings.com/hc/en-us/articles/205382174-Samsung-SmartThings-Multipurpose-Sensor-2015-model-

Give these steps a try and you should be good to go. If you do have
questions or still need assistance please don’t hesitate to chat in or call
1-800-SAMSUNG (726-7864) between the hours of 8:00 AM - 5:00 PM PST Monday -
Saturday. You can also email us at Support@SmartThings.com.

Kind regards,

Steve
SmartThings Support Engineer


(Brad) #15

Resetting the sensor won’t help, we need a code fix. I can pass on the feedback to the support team and can update this thread when the fix goes out.


(Scott Grabauskas) #16

Thanks, Brad. I reset the device, obviously with no resolution of the
problem. I just posted the reply that I received to keep the thread
informed. I’m anxiously awaiting a fix, we have been using our 3axis
sensors for lighting control for months. Now that I have to flip switches
and set levels manually I’m realizing how much I enjoy the Smartthings
benefits. #firstworldproblems


(Ryan Applegate) #17

The three axis issues should now be resolved.