ThingLayer: An open source real-time web interface for IoT

I can not open the locations tab. I have tried on a server I setup and your hosted server. Could it be something in my ST account?

You should get a drop down. Add your first location. I have checked it on the live server and my testing server.

Tried on 2 different computers with IE and Chrome. Both clicking on Locations and hovering over it. Nothing happens. It adds a ‘#’ sign to the end of the web address it is currently on. ‘https://thinglayer.net/dashboard/index’ to ‘https://thinglayer.net/dashboard/index#

What if you just go straight to this address

https://thinglayer.net/locations

@MikeDL

There is no add zone or location. Should there be one?

Looks like you have found a bug. I will fix this tonight.

Awesome!
Have you tried the grovestreams setup? Do you know the differences?

I have tried GroveStreams and I think they offer a great service. They have a great sensor monitoring solution that is fairly easy to set up. ThingLayer has been designed around the home with control, monitoring, and data analysis in mind.

I’m currently running GroveStreams and it’s kind of bland. Any word on that update to fix locations?

I signed up… imported all my devices

I see nothing on the dashboard…

Not sure what i did wrong…

@MikeDL @BatraD Sorry for the delay. I have been moving all of my equipment. I have fixed the locations bug that was preventing new users from being able to add locations.

@BatraD The first step is to add a new location. Once you have a location, you can start assigning devices via the things page.

@jodyalbritton Jody … Thanks. i added a new location, i still cant assign things to a Zone

i don’t see any zone in the drop down when i click on an item under Things and can’t see anything on the Dashboard… …

@BatraD You add zones to the location you created. In the sidebar, Click locations, then the location you just created. You need to create a few zones. Then the box will be populated on the things page.

@jodyalbritton - -Thanks… I was thinking Locations are zones and never created a Zone under location…

Things now show up on the dashboard

Quick ? Why do dimmers show up both as a switch and a dimmer ?

Thanks for your help

Each function is treated as its own device. You can deselect the visible on dashboard box if you don’t want the switch to be visible.

I signed up but my dashboard is empty even after authorizing my devices. Is there a step that I missed?

Create a location then create some zones. Assign your things to zones.

@April can you merge this thread with this one? The following is the current thread.

1 Like

I have a lot of changes on my testing server. Some of them would have been breaking changes so I have been trying do the migration in a way that preserves historical data. The original setup I had with firebase was becoming untenable for the hosted version at ThingLayer.net. There are over 100 new features coming in the next iteration. This is just prep work for that. I should have it fully migrated by July 15th, so that’s when I would start the docker work. Feel free to ask any questions or make suggestions.

Thanks for your help.

I looked through the updated website (thinglayer), and the old data is missing (at least for my instance). I haven’t had a chance to reimport the data from ST…but I am assuming that could work?

On the docker front, I am working on building out the containers now. I am using Ubuntu 14.04, since your instructions were for Ubuntu; it just makes everything…easier. I’m building two; one for your ruby environment and application, one for the MYSQL environment, and then I will link them on the Docker backend to prevent unnecessary port or security exposure. I’m also building them from scratch because even the default containers from Ubuntu needed to be upgraded, and many of the containers on Docker Registry Hub have nasty vulnerabilities like heartbleed, etc. That’s all we need is for someone to get ripped up from the inside out! Not on my watch…(I’m a security guy by trade). Once they’re built, tagged etc…I will put them on Docker’s Registry Hub for you to instruct folks on grabbing them. I also have a massive backlog of containers I should put up…I just haven’t had the time.

More to come soon…sorry it’s been taking longer than expected, but my regular job consumes a lot of my time! :smile: