SmartThings Community

Thermostat settings?


(Daniel Pena) #4

I would use CoRE and have it set itself back to 75 if it’s adjusted below 75 along with a message, eventually they’ll get the clue that thier adjustments aren’t doing anything.


(Bobby) #5

You can use core/webCoRE to do that. Or if you just want a specialized app that does just that, you can use this one…( I created to solve this very problem - there was a war between my wife and our oldest. He wanted much warmer, she wanted a lot colder. Neither one won in the end, as my thermosts reset to my desired temperature regardless of their manual overrides)


#6

I have no idea what to do with that coding. Do i copy and paste it somewhere? My computer programming skills from my college courses arevery limited. :joy::joy::joy:


(Bobby) #8

I know @JDRoberts has a FAQ on how to install a custom app. But yes, is just a copy/paste and a bunch of click ‘done’ …

Essentially, you need to find your way into IDE and navigate to Smartapps to copy and past the custom code. Then you go back to your mobile app and go through the app settings…


#9

Unless this is broken down step by step. I honestly wont be able to do anything. Can someone link a forum that breaks it down?


#10

Yup, check this out:

http://thingsthataresmart.wiki/index.php?title=Using_Custom_Code


#11

Thank you!!!


(Bobby) #12

Come back here after you try your hand at installing a custom app. We will help you get through, if you get stuck…


#14

Another FAQ :wink:


#15

Okay. So Ive published it. However under smartthings marketplace nothing is showing up for my apps. I logged out and logged back in and still nothing


#16

Is it possible you are logged into the wrong shard. Check to see if you can see your hubs and devices.


#17

Youre right. So how do I get these things to show up on my developer account. Nothing is there and it says use the smart things app but they are listed there in the app…


(Bobby) #18

Ok, now go back to ide, then go back to the code and click publish for me.

Then go to my apps on mobile app


(Bobby) #19

See where it says ‘status’ that should say published then under add a smart app, my apps, you should see this…(zwave thermostat manager)


#20


#21

I had to mess with oauth to get it to publish. Still not showing up on my smart things marketplace


(Bobby) #22

You clicked

add a smart app then
(under + more) you clicked + My App

and is nothing there?


#23

I finally got it. Can you post a screen shot of your settings? I feel like this is a lot like another smart app.


(Bobby) #24

My app looks slightly different than the one you just installed (as far as the wording)… I will have an updated version by the end of next week…


(Bobby) #25

If you only use the internal thermostat sensor, you don’t need to enable the remote sensors, it will automatically look at the thermostat. You set a high and low setpoint (which can be the same) and every time the internal sensors reads more or less it will adjust itself to the temperature you want…So in your case to maintain cooling at 75, your settings would be something like this…

This reads, if the temperature falls below 75, then set (or keep thermostat in auto mode) and set a cooling temperature of 75. (78 heating respectively).